前 言

《实图书业管理系统》由广州市实图软件开发有限公司开发的新一代图书管理软件。该系统适用于图书、音像、报刊、杂志等行业出版物的发行、批销、零售。该系统不但集成了图书行业的进、销、存、配送、统计等计算机现代化的管理功能，且具备与Internet实时、分时交换信息的功能，并可与网上书店紧密联接，方便实现上传、下载数据功能。利用软件的互联网技术，可与出版社、供应商、客户之间方便的进行数据交互，信息共享，加速整个销售环节的运转效率。实图书业管理系统功能齐全，用户界面直观、标准的Windows风格、操作简易，书目、资料检索全面、查找简单、方便以及电脑智能、完善的统计分析报表，为广大图书批发商、和零售商实行电脑化管理提供了良好的条件。

WTO，意味着中国书业将进入一种没有退路的竞争。而管理创新是提高自身国际竞争力的关键因素，这其中又以无纸化、网络化的信息管理为基础，它必须能及时汇集并处理信息，搞好市场预测分析，使经营决策建立在对市场信息充分及时了解和认真分析把握的基础上。

《实图书业管理系统》是现今互联网时代中国图书行业的首选软件。


1

人员准备情况是根据本身的实际情况而定，不可一概而论。单一的零售店可能操作员和管理员是同一个人，而大型的卖场，操作员还细分为零售、进货入库、财务等操作人员。另外，通过人员权限的分组管理，还能将各类人员按组进行权限的分配管理。

1、软件操作员

软件操作员要求能够掌握基本的Windows操作技术及一种汉字输入法，还应知道所从事工作的相关业务流程，如销售业务、收报订或进货等。这样的系统操作员经过一段时间的试运行训练后，可以保证今后相关数据的完整与准确。软件操作员的交替一定要衔接好，避免造成数据混乱。

2、系统维护员

这里所说的系统是指计算机硬件、Windows操作系统和网络设备。系统维护员的职责就是能够保证软硬件的正常运转，在一般情况下，计算机系统能够长时间运行，较少出现故障。一旦出现问题就必须有专业人士解决，所以无论是否专兼职人员，都得在需要的时候及时到场，解决实际问题。

我们提供的远程维护是以计算机能正常运行为前提的。

3、系统管理员

系统管理员是对本软件拥有最高权限的人员（也就是本系统的01用户），由其分配其它操作人员不同的操作权限。


1

1、计算机硬件

CPU：建议采用586 机型、100 MHZ以上。

内存：16MB及以上。建议32M，64M以上更佳。

显示器：普通显示器。（800×600分辨率）设置为256色。

硬盘：系统文件约需30MB空间，硬盘在800M以上较好。

2、软件

操作系统：WINDOWS 9x/Me/NT4.0/2000/XP

后台数据库：Sybase,Oracle,MS SQL Server,Informix,MySQL, Interbase(系统默认)

3、外设配置

（1）条码扫描器

本系统对条码扫描器没有特别的要求，所有的扫描器均可适用。

（2）打印机

本系统的打印适用于所有型号的打印机。如果用户在业务操作中需打印一式三联、或一式五联的报单，故建议用户采用“针式打印机”。并且要在Windows系统中安装好此打印机的驱动程序，否则在打印时会提示错误。目前市场上常见使用的有EPSON LQ-300K+和PANASONIC P1131。只打印零售小票的，可以使用热敏或针打，热敏只能打单层纸，而针打可以使用两联的纸。

（3）POS机设备

POS机相对于电脑，只是增加了顾客显示屏、微型小票打印机和钱箱，另外就是电脑的主机结构更小型，显示器通常采用9寸单显，键盘采用可编程的。这样就组成了一套POS机系统。本软件的专用零售界面适用于门店的POS机零售。


1

1、浏览说明书

首先了解本手册目录内容，可以知道从那里查询所需内容。因为做进销收报订退单的过程都差不多，所以“进货”就讲得最详细，如果对其它的单有不清楚或不理解的，可以去看看“进货”的内容。

2、基本资料录入

基本资料主要指现有的“图书”，“客户”，“供应商”资料的录入，要保证基本资料录入的准确性，因为正式使用时此部分的数据可以保存下来，防止重复劳动。而“用户类别”，“营业类别”和“图书分类”中的各项内容，用户先浏览一遍，看是否适用于自己，否则也请做相应的增加。各项的详细操作请参照相关介绍。

图书资料的录入可以采用“导入书目”的办法，但要导入的书目库中没有这一类书就只能手动录入。

录入完图书、客户、供应商等主要资料后就可以做进货，销售等的操作了。也可以在做单的同时，录入没有的资料。

3、试营业

用户在正式启用本系统前，应该先试运行一段时间，使人员能够熟悉相关的功能及应用。而不用担心试运行时的单据会影响正式启用后的数据。在用户准备正式使用前，原试运行期间的进销存及收付款等数据是可以全部或部分清除的，可以只留下基本资料。具体操作直接与我公司技术部联系完成。

4、盘点

本系统的一个特点是，无须盘点就可以做销售，只是这时的库存会显示负数，并且在每次销售时会提示库存不足，库存查询也得不到有效的数据。所以在正式启用时，一定要做一次盘点，这样在所有用到库存数的地方所反映的数据才是正确的。

但是在首次盘点之前，要做到图书资料基本录入完成；操作人员已经掌握软件的操作；经过试营业，可以开始正式启用。这样，才会保证电脑数据与实际数据的一致性，否则，会给管理上带来不必要的麻烦。


准备工作

1、一种安装情况

在WINDOWS操作环境下，把本公司提供的《实图书业管理系统》安装光盘放入光盘驱动器CDROM中，稍等片刻，则自动显示一安装界面。

首先，选择安装界面中的“安装数据库环境”（系统缺省的数据库支撑环境是InterBase），根据提示按“Next”、“Yes”或“Install”，直到安装结束出现“Finsh”。在Windows9x/Me中，会在任务栏出现一个表示InterBase已经启动的小图标。（Windows NT/2000/XP中此图标不显示出来）

然后，选择“安装应用系统”，根据提示按“下一步”即可。第一次安装时，系统会自动更新一些文件，并重新启动计算机继续安装过程。缺省安装的结果是相关文件在缺省路径c:\program files\stbook下，其中有执行文件ST2001.EXE，而数据库文件stlib则安装在c:\program files\stbook\data下，知道执行文件及库文件的位置是便于今后系统的升级或维护工作。当然，我们在安装过程中也可自行设置安装路径。

安装完成后，将自动在“程序”中建立一个“实图书业管理系统”的程序，并在桌面上建立“实图书业管理系统”的快捷图标。

如果用户需要在同一台电脑上安装两套以上的本系统，只要将整个stbook文件夹复制到其它盘中就可以了，运行时双击该文件夹中的st2001.exe文件就可以了。

2、另一种安装情况

在WINDOWS操作环境下放入光盘没有出现安装界面。

双击“我的电脑”，再双击光盘盘符，双击“Setup”图标，出现与前一种情况相同的安装界面，这时的安装方法是相同的。


主要窗口说明

1、登录

双击“实图书业管理系统”的图标（或，出现如图示登陆窗口，窗口的下方会有日期及时间显示，用户确认后就可以登陆了。否则双击任务栏中的时间，在出现的“日期/时间”属性窗口中，调整为正确的值。

系统的初始操作工号为01，密码为123456。

2、注册

点击菜单栏中“帮助”下的“注册”，在注册窗口中输入实图软件公司提供的编号、系列号、书店名，按“确定”即完成注册，注册完之后才是正式版。否则过一段时间系统会提示过期并要求注册（也就是仍做试用版处理）。

3、修改密码

登录成功后，为了系统的安全性，用户最好将密码修改。修改密码是在菜单项的“系统维护”中，选中其中的“修改密码”，输入“原密码”（123456），并在“新密码”和“密码确认”中输入相同的新密码，再单击“确定”就完成了重设01用户登录密码的工作。新增的其它用户，操作相同。

最后选择“系统维护”中的“重新登录”或者关闭系统再重新启动“实图书业管理系统”，这时要输入新的密码。更详细的操作参见后面有关章节。

4、系统参数设置

在“系统维护”中的系统设置下的“系统参数”里，可确定本单位信息，以及是否启用“ISBN号唯一”、“成本价检查”、“营业类别”，“默认本地仓”和“图书折扣”是否选中等等，各项的具体作用在后面有详述，请参照。

5、打印设置

各书店的打印格式不尽相同，所以事先设定并调节校好打印的样式，可以方便工作。在“系统维护”中的“系统设置”下的“打印参数”窗口中，用鼠标选中是打自定义单还是标准单。标准单是无法修改的，而自定义单则相当灵活，可由用户自身确认各式的打印样式。具体使用参照后面。


基本操作说明

1、《实图书业管理系统》的卸载

在卸载《实图书业管理系统》前，首先要保存好两个文件：一是最新的系统执行文件st2001.exe；另一个是数据文件stlib，也是最重要的。其位置在“一种安装情况”中已经讲过，可参照。将这两个文件存储在除C盘以外的地方，即使重装Windows操作系统也不会丢失数据了，只要文件恢复到对应的位置就行了。

卸载《实图书业管理系统》的步骤：单击“开始”→“设置”→“控制面板”→双击“添加/删除程序”→单击“实图书业管理系统”→单击“更改／删除”按钮，然后在出现的窗口中选择“删除”项并选择“下一步”，根据提示就完成了卸载过程。

２、数据库环境的卸载

这里的数据库环境是指系统默认的数据库——InterBase。其卸载情况分为两个步骤：

（１） 单击“开始”→“设置”→“控制面板”→双击“InterBase Manager”图标，在出现的窗口中单击“Stop”按钮，关闭此窗口。

（２） 在“控制面板”中，双击“添加/删除程序”→单击“InterBase”项→单击“更改／删除”按钮，然后在出现的窗口中选择“Uninstall”项并选择“Next”，根据提示就完成了数据库环境的卸载过程。


鼠标器的外形象一只老鼠

鼠标器的外形象一只老鼠，用手抓住鼠标器，将它放在桌面上下左右移动，就可以控制计算机屏幕上的箭头（或是其它形状）移动，鼠标器的前端有两个或三个按键，利用这些按键就可以完成许多操作。

鼠标的左键和右键有不同的作用。一般把左键设为主按钮，按下左键执行正常选定等操作；按下鼠标右键后弹出快捷菜单，快捷菜单中列出的是和鼠标指针当前位置有关的一些快捷操作。

鼠标器的基本操作有以下几种：

单击：即按下鼠标器左键，然后立即放开。单击一般用于选择操作、光标的定位、选择下拉列表框中的选项等。在以后的描述中，“用鼠标单击”或“点击”即表示按下鼠标左键。

双击：即快速地按两次鼠标左键。双击一般用于启动执行或选中相应条目或显示有关信息。

拖拽：按下鼠标器左键不放，然后移动，可将选择的对象拖至指定位置或将鼠标拖拽区域涂黑。

右击：在某个特定的区域快速地按下和松开鼠标右键，用于弹出与当前位置相关的快捷菜单。


显示一文本

显示一文本（字）输入框，包含下拉按钮，表示可从下拉列表框中选择输入。有的输入框仅可以从现在列表中选择，不允许用户键入；有的也可由用户键盘输入。当单击下拉按钮▼时，就会显示可供选择的项目列表。如在销售单中单击“购货单位”的下拉框，将出现如图所示的列表。


单选按钮为圆形

单选按钮为圆形，通常是成组工作，当用户单击组内一个按钮时，该组的其它按钮无效，不能再被选择。当某单选按钮被选中时，按钮中包含一黑点。若未被选中，则按钮中间空白，无效的单选按钮模糊显示。如右图所示：


复选框与单选按钮不一样

复选框与单选按钮不一样，如右图。无论有多少个复选框，他们都可以独立地开关。当复选框被单击时，框内包含一“√”，再单击则取消被选标志。若未被选中，按钮中间空白，无效的单选按钮模糊显示。


为了便于用户在键盘上完成大部分的操作

为了便于用户在键盘上完成大部分的操作，而不用频繁地在键盘与鼠标之间换手。在窗口中的所有按钮，都可以用Alt+相应字母提示使用，其作用与鼠标在按钮上单击一样。灰色表示此按钮暂不能使用。右图“新单”按钮可以用组合键Alt+N（先按住Alt键，再按一下N键，松手）选择。


在所有日期选择的地方

在所有日期选择的地方，只要单击该日期栏的下拉按钮，就会出现一个日历表，选择本月的几号，直接单击相应数字；选择月份，可以按左右方向的两个箭头，也可以用鼠标点击如图中的“8月”的8，如图出现一个下拉的月份选择框；选择年份，单击年份的数字，如2001，会出现一个选择框，供用户方便选择年份。也可以直接在相应位置输入而不用下拉按钮，如点击“2001年8月7日”的8处，再键入6就会将8改成6。


在系统的进销存窗口

在系统的进销存窗口、各类查询窗口和功能分析窗口中，有许多需要输入数据的地方，提供了智能化的模糊输入法。

在进销存中的所有业务单据窗口，都提供了两处可使用智能化输入法的地方。一是“供货单位”和“购货单位”，另一处则是在明细中选书栏处。

在“供货单位”或“购货单位”栏的第一个空白处，可输入相应的进货或购货单位的编号（系统自动生成）。也可以输入简拼，如目前有一“广州市测试书店”的单位，只需要输入“cs”（“测试”发音的第一个字母）并回车，就可自动找出相应的单位并在第二个空白处列出。当然输入简拼是任意的，只要是连续的就行，其它的简拼组合还有：cssd（测试书店）,gzs（广州市）,gzscs（广州市测试）,scs（市测试）,css（测试书）……。当然，我们也可以在这里直接输入单位名称的一部分，如：“测试”两个字，按回车后，在下一栏也会出现相应的单位。

在选书栏处，我们也可以使用与上面相似的方法，可以用ISBN码、简拼和书名的部分或全部。 同样，在其它的一些窗口中，我们也提供了这样的输入方法。在输入数据时，建议多使用系统提供的简单快捷的输入方法。


资料录入的工作是系统在使用时

资料录入的工作是系统在使用时，首先要做和经常要做的一件事。为了系统能正常运行，不会因分类的随意变化而造成系统分析的混乱，这里的许多录入内容最好先规划，如：营业分类、图书分类。下面将详细讲述图书资料录入，其它的则简单介绍。


图书资料录入

1、窗口布局

（1）功能按钮

包括增加、修改、删除、保存、取消、打印、查找和退出。当按钮以灰色显示时，表示此按钮当前状态下不可使用。每个按钮前的字母表示快捷用键，具体用法前面已有介绍。

（2）基本资料

基本资料页面包含上图所示内容。添加书目库中没有的书时需要使用。其中，条形/自编码或ISBN/ISRC、书名、出版社、定价是必填项。单击“保存”按钮或是按Alt+S保存。

条形/自编号的作用比较灵活，用户可根据自己的实际需要，输入条码或指定某种自编号。并且在“图书查询”、“库存查询”功能中可以查询，在进销存退的窗口中也可使用。如果用户不用“条形/自编码”，可直接回车，跳到ISBN/ISRC。

ISBN/ISRC 号采用国际标准自动检查，不是标准书号会有提示，如果用户需要录入非标准书号，则在打入ISBN号后，用“Tab”键转到下栏。（如果将“条形/自编号”与“ISBN/ISRC”号的输入顺序对调，可以在“系统维护”下的“系统设置”中“其它参数”选择）

出版社是自动根据标准条码或ISBN号给出的，如果未出现，请在“资料录入”的“出版社”项中添加（请参考有关内容）。

自定义类别可将图书或其它资料进行分类，便于统计分析、查询。

进货折扣和销售折扣在进销过程中起作用，必须确定“系统维护”->“系统设置”->“折扣管理”中的相关项被选中。如：销售折扣，当用户在销售单中扫描到这本书时，折扣数会自动在销售单的折扣一栏中出现，无需用户另行录入。销售折扣可以提供给批销和零售使用。进货折扣可在库存查询用于计算库存实洋。

进货价音像是系统针对采用实洋管理设置，如做特价书、音像或是其它百货类，它们一般没有图书那样的定价。对采用定价折扣（码洋）管理的用户无用，可忽略。

对于营业类别、经营类别、ISBN分类、开本和介质，如果你想对图书进行某种分类，方便以后对某一类别的书进行查找的话，就在此选好。（按▼可以弹出下拉菜单进行选择）。这些类别也可根据自己的需要做相应增删修改，它们在后面将讲述的“营业类别”和“图书分类”的各子项中。

期初库存只在第一次录入时生效，保存后修改此项将不会发生作用。

（3）其它资料

图书资料录入窗口中，还有三项其他资料录入页面。

详细资料：作者、译者、版次、装帧、印张、印数、页数/字数、次数和备注等。

目录/内容：有目录和内容概要两个栏目。

封面/图片：主要是指图书的封面显示。而具体的封面/图片处理是在点击“查找”按钮或选择菜单中的“图书查询”项后出现的窗口中，我们将在后面讲述。

2、功能使用

（1）增加

点击“增加”按钮或按Alt+A键，就可以开始输入一条新的图书记录，其中ISBN号、书名、出版社和定价四项内容为必须输入的。这时只有“保存”、“取消”和“退出”按钮有效。当定价输入结束并按回车时（按Tab键可直接跳到下一栏），系统会自动提示“是否保存”，直接按回车即表示确认保存。

继续下一条的输入按上述步骤。

（2）修改

可修改刚保存的图书或是以前录入的图书。对于以前录入的，一般步骤是：首先单击“查找”按钮，输入适当的条件，找到相应的图书并双击，当前窗口会转到“图书资料”窗口（这时相应的图书信息已经在此窗口列出），再单击“修改”或按Alt+U按钮，修改完成后保存即可。

要修改当前录入并保存后的图书资料，可以直接单击“修改”按钮来完成。修改完毕之后请记得要保存。

（3）删除

与修改的步骤相似，按“查找”，在弹出的“检索书目”窗口中找到相应的图书，用鼠标双击则自动跳到“图书资料”窗口，单击“删除”按钮就可以删除一条图书信息资料。对于刚保存的可直接删除。

（4）保存

在增加或修改后，单击“保存”或Alt+S，可以将该记录保存起来。

（5）取消

在增加或修改过程中，取消当前的操作，恢复为该操作前的状态。

（6）查找

在资料录入窗口中，为了便于用户即时了解所需图书，系统提供了一个查找的功能。单击“查找”按钮或Alt+F，即可调出图书查询窗口。根据查询条件找出相应的图书资料，并可双击某一条记录，该条记录立即出现在“图书资料”窗口中。

对于该功能的使用将在“查询分析”菜单下的“图书查询”中详细叙述。

3、ISBN号简述

ISBN号录入是由扫描枪或手动录入，系统将自动识别10码和13码（EAN），只要与书目库的ISBN号位数统一就行。如：书目库中ISBN为10码，而扫描器设置为13码就无法扫出相关图书。是否保持书目库的ISBN唯一，由用户设定，只要将“系统维护”项下“系统设置”中的“系统参数”页面的选项“ISBN唯一”选中就可以，这样每当有重码时，系统都会提示。至于重码的图书，则由用户考虑如何处理，一般是用条码机另行制作或用激光打印机打印。

对于某些情况，如新书报订时，只知书名和定价，这时ISBN号可以自已随意录入，但要在收到书时修正、更新。

对于正确的ISBN码，系统会自动给出相应的出版社，除非是系统中没有录入相关的出版社或是新成立的出版社，这时要在“资料录入”项下的“出版社”中增加有关出版社。如：ISBN为7-111-08575-2的一本书，其版别号为111，简称为机械工业，出版社全称为机械工业出版社。（注意：手动录入ISBN号时，不要录入“-”号，否则系统无法识别。）

4、同ISBN号的处理功能

在做图书录入时，如果在“系统维护”的“系统参数”中选中“ISBN号唯一”项，则在录入ISBN号时，相同ISBN号的书会出现在下方一个列表中，这时用户可以查看列表，并做取消、修改或复制的操作；未选择“ISBN号唯一”，但录入时，ISBN号和书名相同时，也会出现一个同样的列表。可按实际情况进行以下三种处理方法：

（1）取消出现的列表窗口，自行录入其它内容。可以在列表头处单击鼠标右键或按ESC键，取消后继续录入图书资料的其它内容，保存后，图书资料库增加一本。

（2）修改列表中的书。只要双击所选书即进入了图书资料修改状态，保存后资料即被修改。

（3）复制某个图书资料全部内容，修改后，以新的资料保存起来，即在资料库中会增加一本新书，而不影响被复制的资料。操作步骤：选中列表中的某条，再单击“复制”按钮，列表中所选书的资料出现在窗口中，做适当修改并保存。注意即使不修改任何内容，保存后也将做为新书保存起来，资料库中会有两条完全相同的图书。

5、异常ISBN号的处理

系统对9787（EAN13码）开头及7（ISBN码）开头的条码号，遵循标准自动计算出校验位，其它开头的则不作限制，可自由录入编码。如果用户需要使用，但系统又提示条码不正确时，可以按“Tab”键跳过，只是需要手动录入出版社简称。图书资料录入后，在进销存扫描书号时，不会影响使用该书的查询及调用。

6、资料录入的顺序

此处的录入顺序，指每按一次回车键，输入的焦点将停留在哪一项。图书资料录入窗口中，有三个复选项：连续录入、录入期初库存、录入非图书。

以上三项全不选的按回车键顺序：“增加”→ISBN号→自编号→名称→出版社→自定类别→售价→进货折扣→销售折扣→“保存”。再录入新的资料时重复这个步骤。

选中“连续录入”，将在“保存”后，自动进入录新书状态，即不用选择上面的第一步（选择“增加”按钮）。需要连续录入两本以上的资料将会更方便一些。

“录入期初库存”选中，最后的几项顺序是：销售折扣→期初库存→“保存”。

“录入非图书”选中，最后的几项顺序是：销售折扣→进货价音像→“保存”。

如果“录入期初库存”和“录入非图书”一起选中，最后的几项顺序是：销售折扣→进货价音像→期初库存→“保存”。

还有一项参数选择将会影响录入顺序。在“系统维护”→“系统设置”→“系统参数”中，选中“默认使用图书编码”为“自编号”并“确定”后，录入图书资料将从“自编号”开始，而不是上面的ISBN号开始。


New Page 1

单击“增加”按钮，开始录入供应商资料。名称、类别、地区是必填项目。为了系统能顺利执行其它功能或是功能扩展的需要，所列项目中，最好能将联系人、城市、邮编、地址及电话输入。总之，资料详细便于系统分析的准确性，或是打印的需要。

“名称”旁边的第一栏是由系统自动生成的编号，用户只需在第二栏输入名称并回车，第一栏的编号会自动添加。

“详细资料”页面中，则是供应商其它的一些信息，如成立日期、登记编号、注册资金、法人代表等。这里面有一项“会员编号”比较有用，这个编号必须是字母与数字的组合，而且要字母开头，这样可以区别于系统自动生成的编号。在后面要讲的“进货单”中，就可以直接用编号选择供应商。

供应商的资料中，有两项可以灵活使用，即“类别”和“地区”。系统为类别分了几个大类，用户可以按需要再增加更多的类，此项的增改删可以是在“资料录入”→“客户类别”→“客户类别”窗口中操作。


客户输入窗口与

客户输入窗口与“供应商”输入窗口相似，要求也基本一样。

为了区分内部客户和外部客户，在客户资料的“详细资料”页面中，如果会员级别选择“内部”，在单据查询页面2中就可以按“客户类别”（分内部和外部）查单据。如果会员级别没有“内部”选项，需要在“资料录入”菜单下“客户类别”中的“会员级别”窗口增加一条客户级别是“内部”的记录。


这里的会员资料内容与客户一样

这里的会员资料内容与客户一样，但只针对零售客户，并且零售客户是采用会员编号来进行管理的。每一零售会员对应有级别、编号、折扣等，可以在限额或客户/供应商查询中查看该会员的消费总额。可以支持IC磁卡或有关的条码设备。

会员可以按期限设定会员的有效期，也可以在“折扣管理”设置会员的消费金额级别，消费总金额数到达某个量后，享受更多的优惠折扣。


在系统中

在系统中，已经存在一个统一的出版社库，为了适应新的出版社产生或其它变动，可以在这里增加或修改、删除相关的出版社。出版社的录入界面，“版别代号”是出版社的固有号码，也是ISBN号认别出版社的标志；“简称”指出版社简称，在本系统中显示的出版社名都是按简称，可选取4——6个汉字；“出版社全称”即全名；“版别分类”可以不输入。

有些出版社的条码在印刷时因某些错误或质量，造成出版社无法识别，即使在此增加有关出版社，在图书资料录入时，也会出现扫不出条码的情况。处理方法可以手动录入条码，或是在出版社栏手动输入（无条码的音像产品会出现较多的此种情况）。


系统自动创建一号仓

为方便有多个仓库的管理。系统在数据操作时以“仓号”区分。用户可按自已使用情况统一编订，“仓号”不能重复，以方便区分。“仓库名称”记录位置。如可这样表示：“仓号－A11”、“仓名－第1仓库1号”，或再补充说明如：“备注－靠近楼梯口”。下图为新增仓库的操作界面。

系统自动创建一号仓，并将其默认为本地仓。“系统默认本地仓”的作用是在做进销存操作时，仓库这一栏都自动填入默认值，如果一号仓的仓号是“1”，则自动填入的值就是“1”。一旦用户有多仓情况，就可在此增加。如果要改动系统默认仓，可以在“系统维护”→“系统设置”→“系统参数”页面里的“默认本地仓号”中修改，并确定。


客户类别使用户按自已的使用习惯定义

客户类别使用户按自已的使用习惯定义，按“供应商、客户”单位性质分类，方便查找。如可分类：出版社、一级批发商、二级批发商、个体户、零售”等。

客户类别中还有一项是“会员级别”，可将不同客户定为不同的会员级别，方便在进行销售时予以不同的优惠折扣。

这两项内容都是可以进行增加、修改、删除操作的。


1

1、营业类别

对经营项目进行分类。可在统计查询中使用到。系统选用“图书”或“音像”。若经营有多种印刷品的用户，都使用本系统来同时管理，则可增加“报刊、杂志”等。同时也可在此输入相应的税率，如系统默认：“图书－13%”、“音像－17%”等，则打印表单时同时显示出来，方便财务方面结算。

1、单据状态

“单据状态”可以为每张单设置某种状态，可以方便地进行查找或与其它单区别开来。如系统设置了“新单”、“已到货”和“错单”。

2、发货方式

注明发货方式，主要是在批销单中使用，系统已设好慢件、快件等内容，用户可以自定义。

3、支付方式

在系统的支付方式中，默认有多种方式，建议不要修改，只做增加。

在进退销的做单过程中，提供了包括批发、零售、现金、支票等的多种支付方式，选择不同的支付方式，是有差别的。

在进退销的各种单据中，如果支付方式是批发，则表明此单是未收付款的，其收付款应在“账务处理”中对应项进行；如果支付方式是现金或支票，则表明此单是已结清或是部分已结；选择其它的各项，则均不做为结款处理，全部为未付款，这类单的收付款处理也是在“账务处理”中进行。

零售的处理不同于上面所述，在零售窗口中，不论选择何种支付方式，其结果都是做为已付款。

4、地区类别

“地区类别”中，系统已经建立了一个标准的地区库，一般无需修改。


图书分类的内容

图书分类的内容，大部分是在图书资料的录入中才使用，或者在某些查询中使用到。

“经营分类”指所经营图书的分类，用户可根据自已的经营特色而在此调整。

“ISBN分类”在系统中已经有一标准的分类库，用户可无需改动直接使用。

“图书装帧”、“图书开本”和“征订期号”用户都容易理解，不再赘述。

“自定义类别”指用户可按某种区分类别来区分图书，可在一些查询及功能分析中应用到这个条件。

“介质分类”指存储介质，如可按 CD、VCD、光盘等来分类。

“图书状态”用来标识一本书的当前状态，如正常、缺货。改变状态在“库存管理”中的“盘点”窗口。


进货录入

进货单的主要作用：为对每一供货商每一批次货物的购进建立相关单据；进货单保存后库存数据自动处理；将货物分发到不同的客户手中，形成分发（批销）单。

以下是进货中主要用到的一些内容，在其它一些进出货单中也会经常使用到这些项，必须要清楚它们的作用及使用方法。

1、供货单位

可在两处选择供货单位，一是在“供货单位”旁边的栏中输入；另一处是直接在“供货单位”的下拉框中选择。

在“供货单位”旁边的第一个栏中，有三种输入方法可以确认“供货单位”：在此栏中采用简拼输入，我们输入“rmyd”并确认，会在右边栏自动出现“人民邮电出版社”；如果用名称，可以输入“邮电”二个字或是其它任意连续字样；也可以直接输入该供货商的编号（编号由系统自动生成）或者是会员编号（详见供应商资料录入）。简拼和名称都可以采用模糊查询法，这些，前面已有详细介绍。

如果供货单位的数量不多，在“供货单位”边的第二栏中也可采用直接按下拉框按钮进行选择的方法。

在具体的做单过程中，用户可能会忽略选择供货单位这一步骤，而把其它的步骤做完了，再回头选择供货单位，但这时才发现并没有录入这个供货单位的资料。不退出进货单窗口，打开供应商窗口，等录入完相关的供应单位资料，在进货单窗口中单击下拉框并未发现刚输入的供货单位资料。这时可在前面栏中按一下回车键刷新下拉框中的资料，或是输入简拼、名称，就会出现所需供货单位。

2、支付方式

所有的进出货单据，其支付方式的内容项都是相同的。“支付方式”中的各项内容，在“资料录入”→“营业类别”→“支付方式”中可以增加。通常书店的常用三项是“批发”、“支票”和“现金”，“批发”项指不是当即付款的交易行为，今后结算，此类单需要在“帐务处理”中进行。具体相关内容在上一章已述。

3、统一折扣

如果在此录入折扣，将会在下面明细表的折扣处出现，对于折扣数基本相同的批量图书比较适合，有少量不同折扣数时，也可在明细表中相应栏另行输入。用户也可以在选完书后，在此处输入折扣并回车，系统将提示把明细表里的折扣统一更换。

在图书资料录入时，有“进货折扣”和“销售折扣”两项，用户需要在出货或进货时的折扣栏自动出现该折扣，则必须在“系统维护”→“系统设置”→“系统参数”页面选中“批销使用图书折扣”项。

统一加减折扣。在明细表中折扣的基础上统一加扣，如全部折扣上浮2个点，则在统一折扣栏中输入：+0.02，回车确认后，系统会自动在原有的折扣上增加0.02。统一减扣，则输入“-”号。

操作小技巧：很多进货单是按照供货单位发货单做的，如果折扣比较有规律，而不是很混乱，如前10种为0.5折，后8种是0.6折，再后12种是0.55折。做单时，先在统一折扣栏中输入0.5，不按回车，在ISBN栏录入资料，出现的折扣全部是0.5；开始录入0.6折的书了，在统一折扣栏中输入0.6，不按回车，在ISBN栏中继续录入资料，出现的折扣将是0.6；同样，录入这几本后，在统一折扣栏中输入0.55，不按回车。记住不按回车。这样可以减少录入的工作。但要注意不能选中“系统维护”中的“批销使用图书折扣”。

4、ISBN、书名、简拼

在进货单明细中，我们对于一本书的输入可以采用多种输入方法，系统在这一栏的第一行，提供了一个下拉列表框，有多种可选输入。包括：ISBN号（也可以是EAN13码，系统自动识别）、名称、名称简拼、自定义号、期号和刊号，系统缺省设置可以自动识别ISBN、名称和名称简拼。这些输入内容都支持模糊查询。

如果所选图书有两个以上符合条件的信息，会出现提示框让您选择。如果是分两个以上仓库的，还会出现仓库选择。

如果用户在进货扫描图书ISBN号时，系统提示不存在这本书时，需要即时录入这本书，只要选择“是”就打开图书录入窗口，无须关闭进货窗口，因为系统支持多窗口操作。在图书录入窗口中录入完新书，转到进货窗口，直接按回车（因为原扫描的ISBN号只要没有清除，还是保留在本处的），就出现相应的新书。在整个操作过程中，这两个窗口都可以打开，根据情况灵活转换。

“跳转模式”是指在选书按回车后输入光标的位置移动变化。选中此项，在输入过程中连续按回车后，输入焦点会在“书号”、“数量”和“折扣”之间移动，方便用户录入数据（如果用户在“系统设置”中选中货位号，则会在书号、数量、折扣和货位号之间顺序移动）。如果不选中，适用于用户批量输入一批书，然后修改数量与折扣的操作，按回车时，输入点会从“数量”到“折扣”，再到下一条的“数量”和“折扣”。

5、其它输入框说明

“收取”和“找赊”在这里仅相当于一个微型计算器作用，而且对收报订单是无效的。在进货单、批销单和退货单中，此栏输入数字，系统将会提示是否用“现金”或“支票”，选是，则将此单做为已付款单。其作用等同于在支付方式中直接选取“现金”或“支票”。

“对方单号”和“其它费用”虽然可以输入内容，但对于收报订单来说，在此处没有多少实际作用，用户可以不录入内容。“其它费用”可输入正负数，在进货销售单中有效。

“备注”内容为本单的说明；“结算期限”是为本单设定要结算的时间。

“业务员”处选择本单的是由哪一位业务员所做，便于计算业务员的业绩。

“统一数量”，输入数量并回车，明细中的所有数量都修改了。

“立即分发”，每录入一本书，输入数量、折扣并按回车后，就进入分发窗口（详见进货分发）。

6、常用按钮

除了窗口顶部的几个常用按钮之外，还有以下几个按钮也是用户经常需要用到的。

“选书”按钮一般用在批量选择符合某些条件的图书，这样比直接扫描每本书的ISBN号更为快捷。单击“选书”按钮后，将出现“书目/库存查询”窗口，我们将在“查询分析”菜单项下的“库存查询”中详细叙述其用法。查询符合条件的图书后，只需双击此书（或用键盘上的方向键移到此书并按回车）所在行，该书就会出现在进货单的明细窗口中，然后继续选择其他书。选择结束就可以按“退出”按钮，返回到进货单窗口。

“删除”指删除已经选择的图书，只要将鼠标或键盘将光标移到该行，选择“删除”就可以把这本书从已经选择的图书列表中清除出去。

“进销史”指可即时查询所选书的进销存等历史数据。

“重置仓号”是指将此单的仓库改为其他仓库，如一号库改为二号仓。操作方法是：首先在旁边的下拉框中选择相应仓号，如二号仓；再单击“重置仓号”按钮，明细中的原仓库号（一号仓）就全部更换成了二号仓的编号。

7、数据汇总

在进货单窗口的最下方，是此单的汇总数据。“库存”，表示此书的当前库存数，如果是多仓，会出现类似A/B这样的数，前一个数字表示当前库存，后一个数字表示总库存；“品种数”是此单总共包含的品种；“总数量”为此单的总数；“总码洋”和“总实洋”是这张进货单的统计；“总折扣”在这里是总码洋减去总实洋后得到的数据。“平均折扣”是指本单的平均折扣。

8、生成进货单的操作过程

录入进货单的基本过程：供货单位→支付方式→折扣→ISBN（书名、简拼）→数量→折扣→保存（Alt+S或单击该按钮）。这其中，ISBN（书名、简拼）→数量→折扣可重复做多次选书，最后全部完成，再按保存按钮，保存后会提示是否打印此单。一张进货单只对一个供货商。这也是其它进销退单录入中最常用的步骤。

如果用户在进货时就用现金（支票）付款。可以在“付出”及“找赊”这里使用，在“付出”栏内输入实际现金数量并回车（支付方式未选现金会提示“支付方式”改为现金），并提示保存。付款不足部分会记入此单，即此单只付部分，未付清部分的金额依然存在，可随时在单据查询中查找到该进货单，在进货付款中完成剩余部分的付款操作。

进货单还可由报订单转变而来。用户向供应商订货时需要做一张报订单，当供应商货到时，可将原报订单直接转成进货单，在转单之前，可以修改实到数量及折扣，再单击转进货的按钮。

具体转单是在“查询分析”菜单下的“单据查询”中实现。首先在“单据查询”中查找到相应报订单，再做转进货的处理。一般使用此方法时，供货商的发货是按单张报订单发货，而且最好是品种不多的单张收订单，因为供货商的发货清单与报订单的品种顺序常常是不一样的，当品种一多，校对起来就很麻烦，且容易出错。详细使用步骤在本节的“单据查询”功能中。处理某张品种很多的单，直接在进货单中按供货商的清单录入书目及数量，然而利用分发功能使系统自动修改报订单的订数。

另外一种特殊情况是在“转单处理”中生成进货单，是针对同时有同一供应商多张报订单同时到货的情况，并且需要汇总进货入库，详情请参考“转单处理”中的内容，此种应用情况不会很多。

9、修改或删除进货单

修改或删除某一张进货单，需选择“查询分析”菜单下的“单据查询”，然后在出现的窗口中设定查询条件并找到相关单据，并在“单据查询”窗口中选择“修改”或“删除”按钮，就可以执行相应功能。也可以双击此单调出进货窗口。

进货单的修改与删除操作会影响实际库存，如，删除某张进货单，则库存相应的图书数量会减去本单中的数量。


生成退货单

生成退货单，自动减去库存。自动检测不符合退货条件的图书，并给出相应提示信息。退货折扣按最近一次的进货折扣自动给出。可以选择点击“进销史”按钮，查看一本书的进退货史及现有库存、折扣，以便确定是否退货及退货折扣。在结算中可以查看某一段时间内的退货总额。其操作步骤与前面的基本一样。在此不再赘述。

进货退货单还可在“库存查询”中生成，将符合退货的品种按条件查询出后，转单类型为“转进货退货单”，再单击“转单”按钮，可出现退货窗口。

有关详细的一些操作，可参考“进货”单中的内容。


录入报订单的基本过程

报订是向供货商订书的过程，其结果不会影响库存。录入报订单的基本过程：进货单位→统一折扣→ISBN（书名、简拼）→数量→折扣→保存（Alt+S或单击该按钮）。这其中，“ISBN（书名、简拼）→数量→折扣”可重复做多次，即选多本书。最后全部完成再保存。

一般情况下，可以在做报订单时，不输入折扣，而在实际到货，转成进货单时，再输入折扣。当然，也可以在此处输入折扣数，而在转成进货单时，不需要另行录入折扣（可以另行修改）。

报订单还可由收订单汇总生成（详见转单处理），或是在“库存查询”中转单生成（详见库存查询）。


转单处理的功能是将某类单汇总生成另外一类单

转单处理的功能是将某类单汇总生成另外一类单，如收订汇总生成报订单，下面就以此为例。

首先要选择要被转单的类型（收订、报订、分发），再给出其它检索条件：

² 时间。按单据建立时间或单据设定的要书期限做为检索条件之一。

² 单位。会列出与被转单相关的单位，供用户选择。选择时，可在上方的“名称/简拼”录入，或选中“单位”前的复选框，直接在下拉列表中选择。

² 出版社。该处的出版社只列出相关出版社，而不出现被转单中没有的出版社。

输入检索条件后，再单击“检索”按钮，在下面的列表中出现明细条目；然后在“转单”按钮旁边的下拉框中选择“转报订单”；最后单击“转单”按钮，出现一个报订窗口，相关明细已经出现在报订窗口的列表中。

这时用户可以选择相应的供货商，并保存，完成转单处理。如果还有其它的书也要转入此报订窗口，则先不要按“保存”，而是再次点击转单处理窗口，进行与上面同样的操作。新转的书会追加到报订窗口中。

当报订单保存后，在转单处理中就不在出现已转的书目。

注：此处的转单处理不对相关的收报订订数进行修改，只有在“进货分发”中处理时，才会注销相关订数。在“单据查询”中也可以完成收订转销售、报订转进货，与“转单处理”不同的是它对一张单进行转单，而无需汇总。

转单处理汇总分发单的情况之一。当用户给自己的客户发书时，有时需要将所订货货备齐才发，这时可以按进货情况先做好多张分发（打包不再另售，库存会自动减少），当所有货备齐，再将此客户的分发单在此处汇总生成一张批销单。


在进货窗口和报订窗口中都有一个分发按钮

在进货窗口和报订窗口中都有一个分发按钮，使用报订单的分发一般是在转进货并同时分发（少量品种）的情况下，而品种很多就直接在进货窗口中做完进货再进行分发。这种功能批发用户使用最多，而以零售为主的用户则较少使用。分发操作可以完成以下的主要功能：

² 根据收订单确定生成各分发（批销）单，或直接根据客户名单生成；

² 按实际进货数量修改相应的收订单中的收订数量；

² 修改对应的报订单的报订数量；

² 修改图书资料。

以上功能可以单项完成，也可以组合完成。最常用的操作方式，是将供货商的发货单逐条录入，然后将光标定位在第一条，单击“分发”按钮，进入分发窗口，开始从第一条进行分发。

1、修改图书资料

分发窗口的上部是图书基本资料，包括名称、ISBN、出版社和单价，有些新书在收报订中常常书名或定价不全，这时可单击“修改图书资料”按钮，出现图书资料录入窗口，再行修改。保存后资料就自动修改了。

另外一种常见的情况，做收报订时，图书资料不全，进货时录入ISBN号提示不存在，立即录入正确的图书资料，这时相应的收报订数据并不会在下面的列表中出现，这时就需要用到“检索”按钮及其下方的录入栏。方法是：在录入栏中输入书名片段，支持多个片段，之间用空格隔开，如上图所求图书就可以输入“Studio 宝典”，再单击“检索”按钮，相关收报订记录中有“Studio 宝典”内容的明细就会在列表中出现，最后再单击“修改图书资料”，对应的收报订记录中的图书资料也自动更改。其它的分发工作按照分发的步骤进行。

但对于第二种情况会明显地出现一个问题，在书目中会有两条记录。一条是进货时录入的准确资料，另一条是收报订时录入的不准确资料，处理这样情况的最好方法是做进货单时用收报订时的资料，因为它们的名称虽有差异，但一般相差不大，而且进货是按报订内容发货的，当提示库中没有此资料时，完全可以检索出原先的资料（如用简拼或名称模糊检索），再在分发窗口中修改为正确的资料。这样的结果是将原库中的资料修改正确而不增加新的资料。

2、由收订记录生成分发（批销）单

分发步骤：

a. 修正图书资料，检索对应的收订记录，确定“修改图书资料”，如资料正确则跳过这一步；

b. 确认左侧收订列表中的数量及折扣，并确认同侧的报订列表中的到数；

c. 单击“选择收订”，在右侧的分发列表中就出现已分记录和报订记录；

d. 确认无误后，单击“下一条”，开始另一种书的分发，如果此书不分，可继续单击“下一条”；

e. 最后单击“生成分发单”按钮（可选存成批销单选项），就会将右侧的明细列表按客户生成分发（批销）单，并且相应的收订单订数也自动做了修改。

除了可以按“收订客户”的收订记录分发，也可按全体客户和会员客户，如主动配货就常用到全体客户。

“总数”项是指此次分发的数量，当分发数量之和不等于总数时，系统会有提示，修改总数与分发数量和相等。不做分发的图书在保存进货单时会自动做入库处理。

有几个常用按钮：“不选收订记录”删除左侧收订列表中的某条记录，即此条收订记录暂不分发；“不选报订记录”删除左侧报订列表中的某条记录；“删除分发记录”按钮可以将右侧列表中的某一条已分记录删除；“删除修改报订记录”则删除右侧列表中的报订记录，其作用是可以不自动修改订数。

3、修改报订单订数

可以独立进行，也可以与上面的收订同时进行。当此书有相关的收订及报订记录时，单击“选择收订”按钮，左侧的报订列表也会自动出现在右侧；当此书仅有报订记录而没有收订记录时，需要单击“选择报订”按钮，手动将其选到右侧。

分发窗口的下部，是有关报订单的列表，要系统能够自动修改相应报订单的订数，应选中“修改报订单”项。与当前所选书的有关报订单会在左侧列表出现，并且可以修改“到数”栏中的数量。

如果手动确认是否修改报订单记录中的订数，就不选中“修改报订单”选项，而是每次单击“选择报订”按钮，将相关报订记录转入右侧的修改报订列表。

报订单已经直接转为进货单，无论是选择报订单的分发，还是选择进货单进行分发，都不会出现相关报订内容

注：此处的分发与“出货管理”中的分发是有一定区别的，此处是将一本书分到不同的客户，而后者则是将多种书分到某个客户，每次只能完成一张单。

4、生成分发（批销）单

最后选择“生成分发单”按钮时，可以按客户生成多张分发（批销）单，相应的收报订记录就自动修改。转成分发单与批销单实质作用都是一样的，只是名称不同而已。分发单的名称适合连锁店内部使用，如由配送中心配书给各店，叫做分发单合适；而存成批销单是直接对外部客户的销售。如要生成批销单，先选中“存成批销单”选项，再单击“生成分发单”按钮。

保存后可以按提示信息直接打印，也可以在以后打印。选择“查询分析”下的“单据查询”，找到要打印的分发（批销）单，并单击“单张打印”按钮，按打印单进行备货。

注：“立即返回”选项与进货单的“立即分发”是对应的，此项如果是选中的，当按“选择收订”按钮后，就会自动返回到进货单。“默认”按钮仅对分发客户的类型选择和“存成批销单”项有效，如选择“分店客户”，再按“默认”，下次分发时，出现的就是“分店客户”。


开单工作与前面相似

批销是包含客户信息的销售单，开单工作与前面相似：购货单位→支付方式→统一折扣（可以在明细表中单独修改某本书的折扣）→ISBN（书名、简拼）→数量→折扣→保存（Alt+S或单击该按钮），其中ISBN（书名、简拼）→数量→折扣是循环录入图书过程。确认并选择“保存”按钮，系统提示是否立即打印。

批销单是未付款的，则在支付方式中选择批发（各项更详细的项，哪些可设为已付款，哪些项为未付款，其设置参考后面“系统设置”中的“价格折扣”），隔一段时间后此单要结清，就在“帐务处理”的“销售收款”中完成收款工作。如果用户在批销时就用现金付款，可以在“付出”及“找赊”这里使用，在“付出”栏内输入现金数量并回车，系统提示“支付方式”改为现金，并提示保存。付款数可以不足，即此单只付部分，未付清部分的金额依然存在，可随时在单据查询中查找到该批销单，在“帐务处理”中完成剩余部分的收款操作。（跟进货单的操作方式基本相同。）

因批销时修改数量及折扣较多，所以建议一般用户选择“跳转模式”，会为操作带来许多方便。“统一折扣”栏中输入折扣并回车确定，这时明细表的折扣列会全部修改为“统一折扣”中的折扣数。

批销单与后面的零售单的主要区别就是一个有购货单位，而另一个没有购货单位。但是用户的业务有批发也有零售，可以同时打开两个以上的窗口——批销和零售进行操作，这样有利于用户进行图书分析时（将批销和零售区分开来），保证分析数据的准确性。

如果用户并不想区分批销和零售的分析，可以有另外一种方法解决。即在批销窗口选择“购货单位”为“零售客户”就可以了，并在“收取”栏中输入付款金额，系统会自动将“支付方式”更改为现金，用户只需确认并保存就可以。

“其它费用”可标注为此单付出的费用，如运费、包装费用等，或是去零头的金额数。负数表示在实洋的基础上再减去多少金额，而正数表示为此单额外付出的费用。这些费用也可以在备注栏中加以注明，但它就不会在结算中计算。


零售窗口中虽然有其它方式的支付形式

零售操作步骤与批销相似，只是此处不选择客户。但是，系统针对零售的特点，做了一些输入上的优化。

步骤：用扫描器每扫一本书，系统会自动在明细中列出此书，并将数量设为1，折扣为1，并且输入焦点仍在选书栏，可以继续扫其他书，当都扫描完后，按回车会跳到“现金”栏处，供用户录入收取现金数，再按回车，提示找零和保存，确定完成。用户可以另行修改数量、折扣。

对于修改数量及折扣比较频繁的用户，还可以选择“跳转模式”，使得输入焦点在ISBN、数量、折扣之间转换。“其他费用”可以给客户一个去零的作用，如11.5元，优惠1.5元，要在此录入-1.5。

零售窗口中虽然有其它方式的支付形式，但最后系统都会确认是已付款。所以说，当客户存在不付现的情况时，应在批销窗口中完成，并要建立“客户”名称。因为，实际上的批销和零售并没有什么区别，在此只是有无客户名称的区别，所以只有当用户想准确统计分析批发与零售的数据时，才有区分的必要。

有关的零售折扣管理包括普通客户及会员客户，具体的相关内容在“系统维护”的“系统设置”中讲述。


处理进货后的退货业务

处理进货后的退货业务，与其他窗口一样，打开销售退货窗口后，先选中购货单位，然后再选要退的书，在销售明细单中输入退货数量按保存就完成操作。自动检测不符合退货条件的图书，并给出相应提示信息。自动出现最近一次批货的折扣。也可以选择点击“进销史”按钮，查看针对客户更详细的批销史，以便确定是否退货及折扣是多少。

在“系统维护”的“系统设置”窗口，“系统参数”页面有一项“批销退货只检查上次发货数量”，如果选中此项，销售退货的速度会非常快，因为它只检查最近一次该客户的发货情况，而不会去检查该客户的历史记录（甚至是一、两年的记录）。

参考报订、批销


收集客户的预定单进行登记

收集客户的预定单进行登记，将客户定单输入电脑后，系统会帮助您全程跟踪定单到货情况，随时提供定单的完成以及欠发情况。点击“查找”按钮可完成“收订”转“批销”的工作，自动输入。也可直接选用“单据查询”完成转换（详见“单据查询”介绍）。收订单的支付方式在此并无实际意义。

参考报订、批销


单独生成一张分发单

单独生成一张分发单，与其批销窗口一样，打开分发窗口后，先选中购货单位，然后再选要分发的书，再输入数量和折扣，按“保存”按钮就完成操作。


数据导入功能是一项很实用的功能

数据导入功能是一项很实用的功能，它可以方便地将出版社或其它的EXCEL格式的图书信息导入本系统，也为书店之间交换图书信息提供了方便。还可以将客户的收订数据用EXCEL文件的格式转入本系统，形成收订单。检索客户/供应商与其下的供应商、客户、会员是与导入客户、供应商资料相关的项。

导入书目的步骤：

1、 选择操作类型为“导入书目”；

2、 选择数据文件，即要导入的EXCLE文件，单击“选择文件”按钮，找到相关文件并确定；

3、 确定EXCLE文件中要导入的数据是从第几行开始，共需导入多少行；

4、 确定是否要选中以下导入的条件：

a. 检索书目库。是指导入书目时，自动检索现有的书目库中是否有相同ISBN号的书目，有则不导入。

b. 检索按ISBN+书名。导入时检索现有库中是否有相同ISBN号和书名也相同的书目，有则不导入。

c. 书目数据不带检验码。因要导入的书目中ISBN码的校验位不存在，选中此项可自动生成校验位。

d. ISBN 为空不导入。

5、（可选）系统对一些出版社有固定书目格式的已经设置好对应的列，如导入的正好是这些，只要选择“样式删除”按钮下方的下拉框中的该出版社就可以，最后再单击“数据生成”按钮，就开始导入数据；

6、其它的书目数据导入采用自定义方式导入。需要在右侧列表窗口中的列数栏中（如ISBN、名称、作者、单价等）填入对应项在EXCEL文件中的列数，没有导入项则输入零。如果是一个出版社的书目，则在出版社（不是上条中所说下拉框）栏中输入要导入图书资料是何出版社，以及自定义类别是何种（可选）最后单击“数据生成”按钮。如果是多个出版社的书目文件，则在列表中对应起来，不用输入出版社名称。

7、（可选）常用的样式可以保存，在“样式保存”按钮上的下拉框中输入某个名称，再单击“样式保存”按钮，这种样式的列数就会固定下来，下次直接选择此样式，对应的列数就自动按保存时的设定值出现。不需的样式可删除。

8、（可选）还有的客户需要导入出版社书目信息中的库存数，做为报订的条件。最好的方法是建立一个新仓，专用于存放该出版社的书目及库存。每次导入时，可以选择“库存全部清零”，此项只可用于为出版社建的仓，而不可用于本身的仓库，谨防造成本身真正的库存数据全部丢失。因为这样的仓是临时仓，导入时可以选择“库存全部清零”，以便更新出版社仓的库存。但导入时一定要注意选择正确的仓，否则会将本身真正的仓清零，造成不必要的损失。

查询校验位，是提供给用户确认ISBN码的校验位是什么，常有一些图书信息只知十位码中的九位，没有提示校验位，如将704002350在查询校验位栏中输入，再单击查询校验位按钮，出现结果为4。那么完整的ISBN码应为7040023504。

导入客户、供应商或会员，与导入书目的方法基本相似，不同点在于要选择客户或供应商或会员，并且检索客户/供应商的条件是否选中。其它的一些条件是导入书目所用，无需选择或修改什么。

导入单据，可以导入收订单，用户可将自己的书目信息生成EXCLE文件格式，并交给自己的客户填写订数，再将客户返回的EXCLE文件导入，形成系统中的收订单。导入单据只会用到“操作类型”、“数据文件”、“起始行”、“导入行数”以及对应的列。


提供了多种可选条件进行查询书目及库存

1、库存查询

提供了多种可选条件进行查询书目及库存。多仓会出现仓库选择条件。

输入你要查找书目的有关条件，按“查询”就可以在查询结果中看到你要查的书的相关信息，并按给出的排序条件列出。

如选中库存报警查询，则查询结果显示的是达到库存下限的书。（库存下限的设置在下面作详解）

“库存未动日期”是指显示的日期到现在这段时间内，没有进销退的书。选中其后的复选框此条件才有效。

“清除”按钮是指清除查询条件，恢复到最初始的状态。也可以单独清除某一栏中的条件。

2、按库存报订或退货

系统提供将查询结果转成报订单或进货退货单。如根据“库存报警”条件所得的明细列表，在窗口右下角的“转单”按钮旁的下拉框选择“转报订单”，再单击“转单”按钮，就跳出一报订窗口及相关明细。

根据库存未动确定进货退货的品种，首先要确定库存未动的日期并选中，再按“查询”按钮，在窗口右下角的“转单”按钮旁的下拉框选择“转进货退货单”，再单击“转单”按钮，就跳出进货退货窗口及相关明细。

用户也可以与其它条件组合，细化查询的书目，进行更为有效的转单。


全盘统计各个仓库库存

盘点是一项费时费力的工作，而且盘点不好，将直接影响库存的准确。所以如何提高工作效率和准确性就是盘点要重点解决的问题。盘点方法在这里是最重要的。

首先，我们要详细了解《实图书业管理系统》所提供的丰富的盘点方法。

目前，《实图书业管理系统》提供的盘点方法与库存清零有关，所以我们结合各种清零功能讲述。

为什么要清零？举例说明，当从未盘点就开始使用软件销售，库存数为负数，如A书，库存数为-3，盘点时此书已经没有了，所以也没盘到，如果不清零，那么结束盘点后，A的库存数还是-3。这就不准确了，以后进A书时库存反映也不准确。所以在结束盘点时确定清零的方式就很有必要。

以下是盘点时用到的各种清零方式，当按了“结束盘点”（按“开始盘点”按钮后就会出现）按钮时，下面所选的清零步骤才开始执行，不按“结束盘点”铵钮，所有的清零选择都不会执行。

l 部分书目盘点

部分书目盘点，不影响未盘点的那部分书的库存，也不做任何清零，仅将这部分书目的库存数改成盘点的数量。需要注意的是，盘点的这部分书一定不要在未盘点的部分出现，否则两边都有，这本书的实际库存数与盘点后的库存数就不等。这个功能也经常用于库存校正，比如，发现某书或几种书库存不准，单独就这种或这几种书使用部分书目盘点。

l 库存全部清零

一般做全面盘点时，可以选择这一项。如果是多仓（多仓指除了本地仓，还建立了其它仓，即在“资料录入”的“仓库”中看到的仓超过一个就是多仓），最好不要用，因为它是会把所有的仓都清成零。如果按仓盘点，常选择下一项“按仓号库存清零”。

l 按仓号库存清零

当按仓盘点时，选用这一条，并在下方的仓号中选择一个要盘点的仓号。

l 按图书自定类别库存清零

在盘点时，可以按自定类别进行盘点及清零。比如，先开始盘点少儿类的，完成后按“结束盘点”，再开始盘点英语类的，再结束，再开始……直至盘点完所有的品种。这种方法比较适合于边营业边盘点，但要求相同类别的品种尽量集中在某些货架上，并且这种类别的货不再销售。注意一点，如果是多仓，其它仓的这类图书也会被清。

l 按图书营业类别库存清零

图书营业类别可分图书、音像、文具甚至体育用品等商品，在盘点时，可以按这样的类别进行盘点。注意一点，如果是多仓，其它仓的这类图书也会被清。使用方法与“按图书自定类别库存清零”相似。

l 按图书出版社库存清零

有些批发用户主要经营的图书主要由几或十几个出版社提供，这时按不同出版社盘点也会很方便。使用方法与“按图书自定类别库存清零”相似。如果是多仓，其它仓的这种出版社的书也会被清为零。

1、盘点准备

（1）货位编号

在这里，我们推荐用户按货位进行盘点，为每个货架编号，每次盘点完一个货架后，就选择“保存”。这样可以方便地在“盘盈亏历史查询”中按“货位号”查询，以便校对检查盘点数据的准确性。用户需在输入“盘点数”时再输入相应的“货位号”。

摆放在地上的图书，要排列整齐，也同样的进行统一编号。

（2）图书整理

将同品种放在一起，确认数量，记录在纸条上，并将样书的背面向上，插入纸条。将某一货位的样书搬到电脑旁边等待录入。用盘点枪时，直接扫描此书，录入数量。

发现同品种书在不同位置，无须理会，盘点结束时，系统会自动做汇总处理。

2、开始盘点

首先单击“开始盘点”按钮，系统开始进入盘点状态。“开始盘点”按钮变为“结束盘点”，在盘点没有全部结束时，不可按“结束盘点”。切记。

3、盘点过程

选择了“开始盘点”后，就可以开始盘点工作。因为盘点是一项持续时间长、工作强度大的工作，所以盘点过程的合理化及系统使用的正确性是很重要的。

（1）盘点步骤

就是在“书号”处扫入ISBN号（或是书名、简拼，也可以单选其它的项目），然后在明细表的盘点数栏输入数量，回车，再继续重复以上操作。当工作告一段落或是某货架盘点完毕，这时需要选择“保存”按钮。选了“保存”后，用户即使关机休息，也不会影响盘点数据。

然后继续另一货架的盘点。只要用户没有按“结束盘点”，系统就会始终处于盘点状态，不论是否开关机。但用户要记住按“保存”按钮。

在这中间，用户可能还会使用到这几个按钮操作：“删除”，删除明细表中的某本书；“退出”，退出盘点窗口；“清除”，清除明细表中的所有已选图书。

（2）货位号的使用

“统一货位”可以在不盘点时也使用。如果是按货位号进行盘点，有一个简便输入货位号的方法：先不输入货位号，等此货位的书盘点完时，在“货位号”一栏处输入货位号，再单击“统一货位”按钮，系统将会使明细表中的货位号全部变更为此“货位号”。

不同货位号的同一本书盘点结束后，是按第一次出现的货位号汇总。

（3）盘点数据更正

盘点数据查询是在“盘盈亏历史查询”中，校对数据时，发现有不准确的数据，可删除该书重盘，也可以在盘点窗口中将该书重扫一次，但是在“盘点数”栏中要输入相应的正数或负数（相差的数），使差错数相抵消，结束盘点时系统会做汇总。这种操作只能在盘点状态有效。

（4）盘点机的使用

盘点机对盘点工作可以说是一大解放，《实图书业管理系统》支持盘点机的使用，它可以将书目数据传输到盘点机中，手持式盘点机一般有电池供电，可以移动到任何位置扫描图书，输入数量。最后再通过平台将数据导入电脑，用《实图书业管理系统》的读入数据功能，将数据写入盘点表中。

盘点枪一般都是手持式的，由工作人员直接到某一货架扫描ISBN，确认数量，盘点一定的数量后，再经过相关设备，将数据传送至电脑。电脑中一般会有一个接收数据的软件，允许用户将盘点数据保存为一个文本文件。

在本管理系统中，用户要做的工作就是找到该文件并读入。首先，单击“选择文件”，找到相关路径和文件，并确认，系统会在“选择文件”前的输入框中显示出来路径和文件名。然后，再单击“读入文件”，系统就会将相关书目及数量读入，并在明细表中列出相关数据。

建议有实力的书店采购一套或多套盘点机。

4、结束盘点

当所有盘点工作都结束后，就可以确定是否要选择“结束盘点”按钮了。不过在选择之前，有一些选项用户应该认真确认。

“库存全部清零”，选中此项，则选择“结束盘点”后，系统先将库存现有的库存数全部清零，然后将盘点数做为库存数写入。不选此项，系统只会将盘点中涉及的图书数量写入库存中，而对其它未盘点到的图书库存数据没有影响。

5、其它

“批量修改资料”、“统一货位”和“图书状态”是可以独立于盘点之外进行。

（1）“批量修改资料”，在这里的作用主要是批量修改录入的图书（音像）资料中的内容。修改单价主要为音像（或者是文具等其它采用实洋管理的产品）而设立的，因为它们是按实洋进行管理，而且它们的定价常有统一变动的需要，但是按原来的一条条修改资料的方法效率太低，所以就在此设定了此功能。需要用户注意的是，这些功能相对于盘点是独立的，可以在盘点时修改，也可以不在盘点状态修改。即用户需要统一修改单价、销售折扣、进货折扣或进货价时，只需直接调出“盘点”窗口，选择各品种，再选择修改的内容，并在前面的栏目中输入价格或折扣，最后单击“批量修改资料”的按钮，就完成了整个操作，无需选择“保存”按钮。

（2）“统一货位”，在不盘点状态修改货位号的方法。先选书，再输入货位号，最后再单击“统一货位”按钮（按钮前的栏中内容要清除，保持空白），就完成了货位修改的操作。

（3）“图书状态”设置也可以是独立的，常用来按业务需要确定，选择图书状态，再单击“设置状态”按钮，就可以将下表中的图书状态转换。

6、解决盘点的一些问题

（1）解决盘点过程中数量不准的问题

无论采用什么盘点方式，最容易出现的问题就是数量不对，这些都是人为原因造成的。如果在盘点窗口中当即发现数量不对，可以直接修改它的盘点数，或删除这条再盘一次。为了尽量防止其它影响数字准确性的情况出现，在盘点前就应合理安排好工作。涉及准确性的关键三处工作包括：

l 图书位置，特别是“部分盘点”、“自定类别”或“出版社”这三种盘点方式，否则某些品种就不准确，所以整理货架，同一品种尽可能在同一位置，这就很重要。如果是盘点整个库，这一点就变得次要了，因为所有的书都会盘到，最后系统会做汇总处理；

l 点书，人员最好是两人一组，一人盘好一个品种，并记录，另一人检查校对并将样书搬至电脑处；

l 电脑操作人员，是最后的关键，也是最后一个与数量接触的人，除了在录入数量时多检查，不要录错，没有什么太多更有效的方法。如果也多用一个人监测当然更好，只是用的人力就多了。

如果以上三步都没有问题，这次盘点就是一次成功的盘点。但实际过程仍可能出错，只要知道哪本书出错，问题也容易解决。还可在“盘盈亏历史查询”中随机抽查一些品种看看有没有出错。

这时应还没按“结束盘点”按钮，纠正一本书的数量有两种方法：

一是在盘点窗口中扫描此书，如果此书数量多了3本，就在盘点数栏录入-3，少了就录入少的数量。因为一按“结束盘点”，系统会将它自动汇总的。

二是在“盘盈亏历史查询”中检索出这本书，单击“删除”按钮，它的这次盘点记录就会全部删除，相当于此书没有盘过。然后再在盘点窗口中扫描此书，在盘点数栏录入实际的数字。

（2）解决盘点过后数量不准的问题

盘点工作全部结束后，并未发现有什么问题，但在营销过程中才发现个别品种库存数量不对，这时可以选择“部分书目盘点”进行盘点校正，所盘的就是数量有误的品种。不影响其它品种库存。

（3）解决边盘点边营业的问题

关门盘点会带来一些的损失，特别是大的书城，能不能边盘点边营业，把损失降到最少？完全可以。这取决于盘点的方法，选择清零方式时可以选“部分书目盘点”、“按图书自定类别库存清零”和“按图书出版社库存清零”这三种之一。

我们建议采用“分架盘点”，即“区域分割，逐步收缩”的方法。一般书店的图书都会分门别类地放在货架上，所以盘点时，只要同品种集中在同货架上，可以按货架去盘。比如，先开始盘点三个货架，结束盘点后，再开始盘其他的，直到所有的盘点都结束。正盘点的货架不销售，其它的销售可以照常做。

上面三种清零方式中“部分书目盘点”没有清零功能，不太适合全部盘点；“按图书自定类别库存清零”的盘点，就按所分图书类别盘点，比如，先盘“少儿类”，再盘“文学类”，按这样方法直到盘完，用这种方法的较多；“按图书出版社库存清零”则按出版社盘。

其实，当书店规模不太大，无论采用何种盘点方式，都可以做到边营业边盘点，甚至允许客户购买盘点区的图书。最关键的一点：你要知道客户买的书是取自未盘的还是已盘的。如果取自未盘的，则不用理会，还可做批销或零售单；如果从已盘的取，则要在盘点窗口中扫描此书，盘点数为负的所取数（或者不做此操作，记下此书，盘点结束后补做销售单，但客户要打单的，就不行了）。

只要理解盘点的原理，上面所说的就不难理解。盘点的记录在不按“结束盘点”按钮时，是不会影响现有库存的。当按下“结束盘点”按钮后，系统会先将盘点记录进行汇总，再把汇总结果写到相应的库存表里，这时的库存数就被改成了盘点数，而且在这一刻，每个品种在库存表中的数量与盘点表中的数量是相同的。所以最后的库存数是以盘点记录为标准的。


参考库存查询

盘盈亏历史查询主要用来检索当前盘点记录和历史盘点记录，即在此处记录下每次盘点的情况。一旦库存不准，就可以根据盘点数、进货数、销售数、退货数来确定是哪个环节出现问题，总结经验教训。

对库存盘点的盈亏数据进行查询。从界面上来看，与“库存查询”基本相似。多了几个条件：时间、操作员、盈亏不等于0和盘点统计。选中“盘点统计”所查询的信息是将相重的进行汇总，因为在盘点过程中经常会出现同一本书盘点多次的情况。盈亏不等于0可以检索出有盈亏记录的那部分资料。用户可以根据最后两个条件将有盈亏记录的盘点数据按货位打印出来，确认是否正确，错误的就在盘点窗口中进行排错处理。

盘盈亏记录在此处可以删除，包括正在盘点的数据，当盘点发生错误，需要重新录入某品种的盘点数时，就要在这里将它检索出来，并删除。还可以删除某个时段的所有盘点数据（要选中“全部删除”项）。

参考库存查询


生成转仓单

生成转仓单，库存数量自动转变。此时，系统屏蔽了供货单位，无需在此输入。若用户的转仓过程做为销售过程，应在批销单中完成，即将要转入的仓做为一个客户进行处理。用户在这里可以方便地将转入仓和转出仓的仓号转变。一般转出仓是默认的本地仓。

在“重置仓号”的右边有两栏，首先选择转入仓还是转出仓，再选择几号仓，最后单击“重置仓号”按钮，系统自动修改仓号。


低于下限值的书都存在于

作为销售商，时刻掌握着库存情况才能掌握着市场。所以我们特设一个零库存报警的模块，首先选中要设置的书，选好后它会出现在下方的栏目中。点击某一本书的库存下限，输入你要设定的报警数量，如“5”，点按”设置完毕”项，就可以查看低于“5”这个下限值的所有书。

也可以批量设置下限，先选好书后，在统一下限中输入某个数，再单击“统一下限”按钮。

低于下限值的书都存在于“库存报警”页。


可以统计各种单据

可以统计各种单据（如报定、进货、销售等）在某一段时间内的数据，包括总册数、总码洋、总实洋、折扣金额和未收款项。下图为选择“开始结算”后的界面。

若选中左下角的“分类”，然后开始结算，则会将结算内容分成图书和非图书（如音像）两类结算，因为此二者的税率不同，便于用户分析结算。特别是毛利，便于财务人员进行统计。但是要求在图书基本资料录入时，要区分“营业类别”。

修改结算起始时间和结算结束时间，可以得到日结算、周结算、月结算等等多种结果，还可以结算针对某个操作员的进销存数据，首先要选中“操作员”这个可选项，然后在下面的下拉框选择相关人员即可。还可以将结算类型设为类别零售，按自定义类别结算零售情况，包括其它费用。


用于记录对供应商的款项支付

用于记录对供应商的款项支付，以及对进货单的结算业务。全程跟踪进货帐务结算，并自动提示付款。付款方式多样，可满足多种需求。按“查找”按钮，可以查各类单据，并且在“单据查询”窗口中删除某张进货付款单，系统会将此单重新设置为未付款单。对于已经结算的单请慎重删除操作，因为会影响那一天的结算，因此为相关人员设置权限变得极为重要。系统不提供修改付款单的操作，以免影响系统的结算准确性。

首先，选择进货单位，系统将自动把应付的单在“未付清进货单目”中列出，同时列出预付给该单位的金额；选择“支付方式”；最后用户可根据以下几种情况进行付款操作。

1、结算一张单

只需在“未付清进货单目”中双击该单（或单击该单，并按一下 [image] 按钮），它就会在“本次付款单目”中列出，系统自动在“本次付款”栏填入本单应付的款额，这时只要按“保存”按钮就完成了。系统会自动生成一张进货付款单。并可在“单据查询”中查找得到。此处的总金额合计是指在“本次付款单目”中所有单的总共付款金额合计。

*注意，“金额”和“找赎”这里，只有当付清此单金额时才可以使用，否则即使金额低于“付款合计”数，系统仍会按此单已付清进行处理。

2、一张单，部分付款

只需在“未付清进货单目”中双击该单，它就会在“本次付款单目”中列出，这时只要在此单的“本次付款单目”中的“本次付款”栏内输入相应款项并保存即可。在以后仍可查到此单未付清的余款。如图，即在“本次付款”栏中输入80，系统自动在“未付款合计”栏显示15，表示尚欠，最后选择保存。

当再次显示该单位时，此单的未付款金会显示15。

3、多单付款

与上面方法相同，双击选择准备结算的进货单，系统会自动列出本次付款的数额，直接保存表示全部付清。若总金额不足，则可付清部分单据，不足付清的单,按上面的部分付款方法进行。

4、按销售结算

按销售结算是处理某个品种有多个供货商，需要按实际销售数量与某个供货商结算的过程。确定单击“按销售结算”按钮，出现多货源处理窗口，窗口中有三部分：进货列表、相关供应商列表和某时间段内的销售列表。最后点击“确定”按钮，回到进货付款单窗口，窗口右侧的列表即为要生成的进货付款单，只需单击“保存”按钮就可以。

这里结算的销售数量，是按“系统设置”中“系统参数”的设置来确定的，如先进先出或是最低折扣。已结算的数量，下次将不会生成在进货付款单中。

5、扣除预收款

在以上的进货付款过程中，如果有供货商有预收本单位货款，并且已经在“预收预付/其它费用”窗口中录入过，就会在进货付款窗口中的预收款一栏列出其数额，并且在本次付款时，可以直接从该预收款中扣除。方法是直接在“扣除”栏中输入应扣除的数，窗口中的实付款合计会显示减去扣除数后的金额。

扣除后的金额会在下次付款时继续显示出来。


一

一、进货退货收款

用于记录对供应商的退货回款业务。其界面与进货付款相似，操作也基本上相同。

二、销售收款

用于记录对客户的收款情况及发货单的结算业务，并可自动提示追款。

三、销售退货付款

操作方法与进货付款相同。

参考进货付款


在单据查询窗口中

在单据查询窗口中，也可以查出应收、应付的单据。此处的应收应付款查询主要方便财务部门查询，与对方进行结算。操作很简单，先选择“应收”或是“应付”，再选择时间段，最后单击“检索”就会在下面出现符合条件的单位及其单据明细列表。左侧是单位和该单位的欠款总金额，右侧是所有欠款的单据。

如果不选“未付款”项，在列表中还会出现“结款率”项，方便用户了解结款情况。


操作过程

用户在进销过程中，经常会发生一些其它的费用，比如报订收订会收部分预收或预付的订金，以及销售发货所需要的运费等，类似的费用问题通常都是在此处解决。而且销售中的其它费用也是在此处查询。

操作过程：确定“客户”或“供应商”→是否选择“其它费用”（选中就不做为预收预付款）→选择单位→付款金额→支付方式→备注→单击“确定”按钮，确认保存。

“记录浏览”页面可以查询预收预付和其它费用。


对帐功能

对帐功能，用于跟客户或跟供货商对帐，或者互为总发客户的对帐。

与客户对帐，列表中出现的是四种单：批销单、批销收款单、批销退货单和批销退货付款单，并统计出应收或应付款额。

与供货商对帐，列表中出现的是进货单、进货付款单、进货退货单和进货退货付款单。

还有一种情况，即某单位既是客户，又是供应商，那么相互之间应该有8种单需要对。这样的客户需要特殊处理：

在客户和供货商资料中录入该单位的信息，在客户类别中增加“总发”项，客户资料中的类别也相应设为“总发”。在“客户/供应商查询”中查找供应商，找到该单位的编号，然后在该单位对应的客户资料中找到“会员编号”，并在其中输入编号。

“预收预付参与合计”和“其他费用参与合计”选项，如果选中，也可以加入对帐合计中。

这样，与该客户对帐时，选中“总发”选项，就会出现八种单据的列表。


单据查询窗口可对所有的业务单据进行查找

单据查询窗口提供组合式查询，各种条件充足。单据查询的一般步骤是：1、在窗口中选择要查询的单据类型（如：进货单，只能选择一项）；2、在“查询条件”的页面1和页面2中选择并输入要查找的条件；3、单击页面1中的“查询”按钮；4、最后可对符合条件的单据进行其它操作，如“删除”、“修改”、“打印”等等。

单据查询窗口可对所有的业务单据进行查找。并在此完成收订单转进货单、报订单转批销单的操作，报订与收订与其它单据的主要不同是在窗口的左下角，将出现一可选项：“报订转进货单”或是“收订单转销售单”。

1、查询条件

查询有效性范围包括页面1和页面2的所给条件。

（1）页面1

日期：不选中“起始日期”，选中“终止日期”，表示“终止日期”前的所有时间；两个都选中，并且时间相同，表示那一天；两个都不选中，表示所有时间；“起始日期”与“终止日期”不同，表示在这个时间段内。

单号：当用户知道单据的单号，想调出查看或修改，直接在此输入，这种查询是速度最快的。

单位简拼：在此输入要查询单位（进货单位或购货单位）的简拼，将会在下一栏的“单位名称”处出现相应的单位名称，并使单位名称处于有效状态（即该项的可选框被打上勾）。

单位名称：可以在此处的下拉框中直接选择有关单位，选择之前需将其可选框选中。

未打印：表明查询出的单据是没有打印过的；

未付款：前有一复选框，若选中，则查询的条件之一是单据必须为“未付款”的；

支付方式：按支付分类方式不同查询；

单据状态：包括新单、已到货、错单等，可以在此查询此类条件的单，也可以在此设置某一个单的状态。设置单据的状态时，先选要设置的单据，再选要设置的状态，最后点击“设置状态”按钮，完成单据的设置工作。

（2）页面2

“其它费用不为0”，表示要查询存在其它费用的单据。

“明细状态”是明细表中书的状态，可以检索出符合某种状态的书在哪些单中。

“删单不变库存”是指将某单删除时，并不改变现有库存数量，而正常的删单会改变库存，保证进出的平衡。

“对方单号”，做进货中批退单时，经常会录入对方的单号，此处可按对方单号查找单据。

“客户类型”，可以将单据分成内部和外部客户分别查询。

“单位流水”可以按单位流水号查。必须在“系统设置”的“单号设置”中选中“使用客户/供应商流水单号”，做进销退单时才会有流水号。

“列表打印毛利”，主要打印销售列表（如每月的销售列表）时使用，会在表头列出成本与毛利合计。

（3）列表排序

符合条件的查询记录在列表中出现，上面的是总表，下面的是明细表。总表的顺序可以排列，只要单击一下该项的标题，如“总实洋”或“未付款”等项。也可以按升序排列，方法是选中“升序列表”，再单击有关标题，就按该标题的升序进行排列。打印时就按此顺序打印。

2、功能按钮

查询：当以上的查询条件都确定以后，就可以选择此按钮，系统开始查找符合条件的数据，并将其在下方列出。列出的明细表中，第一部分为汇总单，即每一张单的汇总数据；而第二部分则是汇总单的明细单，其中是每一本书的详细情况。选择不同的汇总单，对应的明细也在发生变化。系统将查询到的汇总单做了几项统计，其位置在本窗口的最下端，包括总码洋、总实洋、总未付款和总数量。

打印：是指打印查询结果中第一栏的内容，即打印查询到的所有汇总单。

删除：即将选定的单据删除，删除单的操作请用户慎重，特别是牵涉到已结算的收付款单据。一般系统对删除的单据会做这样的处理：进货、销售、退货类的数量会对库存做相应改动；收付款单删除后，系统会将与之对应的进货、销售单重置为未付款，并且金额也是相应改动；而报订与收订则不会对库存或金额有何影响。

清除：指清除查询条件，使查询条件恢复初始状态。

退出：退出单据查询窗口。

修改：可以修改查询到的单据，即调出相关单（如进货单）的窗口，但是收付款单暂不提供修改。“修改”按钮的作用相当于双击该单。

单张打印：在第一栏部分移动蓝色条到要打印的单，选择“单张打印”会将该单对应的明细，即查询结果的第二栏部分中的内容打印出来。等同于，此单在保存时提示的“打印单据吗？”。

3、单据转换

（1）报订转进货

单据转换工作是在“单据查询”窗口中完成。

（2）收订转销售

收订转销售与报订转进货的过程基本一样。

首先在“单据选择”窗口中选中“收订单”；

再给出相关查询条件，找出需要转成销售单的收订单；

选中窗口左下角“收订转销售单”的复选框；

双击（或回车）某单，出现一个与收订相似的窗口，不同的是它多了一个“=>销售”按钮，并且在明细表中也多了一栏“实到数量”、“差错数”。在“实到数量”栏里输入实际数量（缺省是报订数），差错数自动计算，以及修改需要变动的折扣数。最后，确认无误后，再单击“销售”按钮，根据提示保存，就完成了“报订”转“进货”的操作过程。

转换后的单都可以在“单据查询”窗口中查找到。

更详细的请参考“报订转进货”。

（3）进货转销售单

将一张进货单转为批销单，可以修改品种、数量、折扣。操作步骤同以上两种转单相似。如果要在进货折扣的基础上统一加点，可以在统一折扣处输入带+号的数（如+0.2），并回车。原折扣就会全部增加0.2。再单击“转批销”按钮，生成的新批销单在“单据查询”中查。

（4）批销退货单转进货退货单

将一张批销退货单转为进货退货单。


在这个窗口中

在这个窗口中，系统提供了强大的组合查询条件，基本上可以满足用户的检索书目的需求。窗口分为三个区，第一个区是查询条件及相关按钮，第二个区是查询结果，第三部分是几个窗口功能按钮。一般的查询顺序是建立查询条件；确定排序方式；单击“查询”按钮；将所得数据进行打印或选中修改。

1、查询条件的建立

查询条件都比较清晰，基本上都是在图书资料录入时的内容。但有几点需要再说明一下。

“定价”一项，在“>=”和“<=”项中填写相同数字表示“=”。

“录入日期”项有两个单选按钮和一个复选框，若复选框被选中才有效，缺省为“>”当前日期。

根据你所知道的图书资料输入查询条件，输入完毕，然后在窗口底部的“排序”中选择一项做为排序的条件，再单击“查询”按钮，系统将符合条件的图书在下面的“查询结果”中列出。

不输入任何查询条件，直接单击“查询”将会提示全部列表出来，之前系统会提示你最好选择一些条件，如要继续请单击“yes”否则单击“no”。

2、查询按钮与结果

在查询结果中，系统给出了相关图书的“书名”、“ISBN号”、“出版社”、“定价”、“期号”、“ISBN类别”、“进货折扣”、“销售折扣”、“自定义类别”和“自定义号”。你可以在查询结果窗口中查看到结果。在窗口的底部，给出了所查找书的品种数。

“选中”指选择某本书，与双击作用相同，结果会出现图书录入窗口，内容就是所选的书。“打印”指查询结果中的所有数据打印出来。“清除”按钮指清除上次输入的所有条件。只清除某个查询条件可以直接将该项中的内容用删除键删除。

状态时间是指设置该图书状态的时间，而非普通状态也是指图书的状态。

3、图片处理

单击“图片处理”按钮后，出现图示窗口，在书名列选择某书，再在窗口左侧选择一个后缀为bmp的图片文件（其它类型的文件将不能保存），最后再单击“保存”按钮，则会在相应的图书资料中出现这幅图片。


单击

“客户/供应商查询“的窗口可以完成查询、修改、删除以及打印的功能。首先在单选框中选择查询对象是客户、供应商还是会员。然后再输入需要的查询条件，单击“查询”按钮就可在下面的查询窗口结果栏中列出结果。如果要修改某个客户或供应商的资料时，只需点击“选中”或双击，就会出现“客户/供应商”窗口，在那里，你可以修改或删除资料。会员资料中还会有汇总的购书金额。

单击“打印信封”按钮，可以打印信封、包裹单或特快专递。

内装何物、保价金额和签名是给包裹单使用的，设好后，再单击“设为默认”按钮，就可以将这些数据保存起来。如果打印不对齐，可以调整页头与左边距。要打印的资料要齐全，如不可无邮编或是联系人，否则在打印时会有出错提示信息。


可以查询某个操作员在某个时间对哪些单进行过什么操作。

操作步骤：“起始日期”→“结束日期”→“操作类型”（可选）→“操作员姓名”（可选）→“相关信息”（指单号，可选）→点击“查询”按钮。

任何条件不选，查询的结果是该时间段内的所有信息。点击“删除”按钮，会删除日志列表中光标所在行；如果选中“全删”的复选框，再点击“删除”，会将列出的所有日志全部删除。


New Page 1

进销收报订史查询可以提供许多非常有用的信息。如单个品种的进货历史；对应供货商的数量及剩余库存数；某段时期内收报订单数量不为0的品种，表示未到或未销；按地区查询进销情况；针对某个单位的列表等等。如果前面的内容基本掌握，这里的操作就比较容易学习。

注意：如果某书的库存数为空，表示这本书已经删除，因为一种书删除，相关单中的该书资料还是保留的，防止出现查单时与原始单据的数量、金额不等的情况。同样，在“单据查询”中，有时会发现明细的书目编号为空，也是表示此书已经删除，仅留在相关单的明细中。


客户分析可以帮助销售商了解某个客户的销售

可以帮助了解客户/供应商的进货、销售、收报订以及退货的情况，按多种顺序排列。

操作步骤：选择购货单位→确定“起始时间”与“结束时间”→选择分析类型（即销售、收订、退货）→点击“查询”。

分析的数据包括总码洋、总实洋、总数量、已结款和未收款，还有结款率。


可以分析销售

可以分析销售、收订、销售退货、进货、报订和进货退货的数据，并按给定的顺序排列。

操作步骤：1、选择分析的对象（指销售、收订、销售退货、进货、报订还是进货退货）；2、再选择分析的时间段（起始时期和终止日期）；3、选择排序的项目（数量、码洋、实洋、库存、出版社、书名）；4、排序的方式，“前”表示从大到小，“后”表示从小到大。选择某个具体的客户或供应商，这是可选项，不选表示分析所有的客户或供应商（选择时，要先将右侧的可选框选中，在“业务员”下拉框的下方位置）。6、最后单击“分析”按钮。

窗口中还提供了一些其它的检索条件，用户可按自己需要查看的数据确定各条件。

批销单分析的结果包括批发和零售，单独分析零售客户时，需在下拉框中选择“零售客户”。

要打印分析结果，只需按“打印”按钮就会弹出打印窗口，在打印窗口中点击“打印”然后“返回”即可。在图书分析/排行榜窗口最下方可以查看到所排序图书的总码洋，总实洋，总数量。

与进销收报订史查询相比，此处的的数据是汇总的数据。

如某供应商，在某段时间内的进货汇总分析，可以得到某种书从这位供应商处总共进了多少本，销了多少本，还剩多少本。所分析的数据是按先进先出或是最低折扣得到，选择手工计算则不会出现销售数和剩余数。

“单号”这一栏，可以输入多个单号，用空格相隔，再点“分析”，可以得出这几张单的明细汇总，但这里的单号只针对某一类的单，如进货单或者是销售单，而不能是几种不同类型的单号。


按系统内设置的各种类别进行统计分析

按系统内设置的各种类别进行统计分析。如自定义类别、ISBN类别、营业类别和介质类别。设置好要分析的条件，单击“分析”按钮，会列出汇总的统计数据。


这里的校验

这里的校验，是根据库存码洋的变动来判断进销退业务数据是否异常，也是判断数据是否准确的一个参考。并可以查询是否有几种情况造成差额的存在。

在正常情况下，即没有删除书目、不修改书目单价以及删单不变库存的情况下，上次的库存总数与库存总码洋，应该与进销退、分发的总数和总码洋平衡，就是差额数应该为0。这就表示库存数量与码洋的变动是正确的。

但有几种情况会影响这个平衡，造成差额的存在，即“查询”按钮旁边的下拉框中所列内容（一般删单不变库存是某些客户有特别的需要时才会使用，建议不使用这一功能）。可以按这几项内容分别查出相关的单及图书编号，再根据这些内容确定差额是否正确。一般情况下，最后的检查结果是与差额相符的，也就是说，由于这几种情况的存在，差额是合理的。

一般的使用方法：库存查询，得到库存总数量与总码洋，分别在“上次库存数量”与“上次库存码洋”录入，并单击“记录本次值”。下一次查询时，直接按“开始计算”就可以了。它会将列出的进货、进货退货、销售、销售退货做一个进出合计，进出合计再与已分未转、库存相加，得出合计值。差额就是这个合计值减去上次库存和上次分发未转的数得出来的。

这个等式是这样的：

差额=（进出合计+已分未转+库存）-（上次库存+上次分发未转）


这个功能是系统能够正常运行的重要条件

这个功能是系统能够正常运行的重要条件。在前面，已作了简略的介绍，在这里将为你详细解说。如在前面有不明之处，请认真阅读本章。目前，系统设置有“单位信息”、“拨号参数”、“系统参数”、“打印参数”、“单号设置”和“系统维护”六项。

1、单位信息

“单位信息”是销售商本单位的一些相对固定的信息，如名称、地区、地址、电话、开户行、税号、联系人等基本资料；还有会员信息、注册资金、法人代表、企业简介等详细资料。你在此输入的单位信息，就是单据打印中的的信息。除了书店是按注册码自动填入的，不能修改外，其他信息你可以任意修改。

2、拨号参数

“拔号参数”是网络用户进行远程登录或是数据传送时，必须要设置的页面。详细的设置分为局域网和远程拨号，网络版用户可以参考后续章节有关内容。

3、系统参数

“系统参数”中还可以设置系统的欢迎画面、主界面底图、以及其它的重要的设置等。以下就单机版用户使用项作一说明。注意，所有项选择后，都要按“确定”按钮才会生效。

（1）营业类别

此处主要是针对音像专营店或其它类型的书店设置，它实行的是实洋管理，去除了关于折扣和码洋的内容。符合这一点的用户可采用非图书类的营业类别。

（2）使用介质

选中此项，在进销存管理中，将出现“介质”栏目。

（3）默认本地仓

对于有多个仓的用户来说，可以确定一个本地仓，这样系统在进行选书操作时，会首先将默认仓做为首选仓库。在进销时，都会显示此处的仓号，并自动增减相应的库存。

（4）使用货位号

选中此项，则在进销存管理中，明细表会将出现“货位号”一栏，用户可以按货位号进行管理。

（5）机号

主要区别POS机的选项。

（6）默认使用图书编码

有些用户因经营品种特殊，希望在进销存过程中选书默认的编码为其它的，如自编号、期号、刊号，就可以在此选择。如，用户全部采用自编号管理，在进货窗口选书处就不是ISBN号，而是自编号了。

（7）货源结算和毛利计算方式

此处有三项可选，即手工计算、最低折扣和先进先出。

手工计算是完全由用户确定多货源结算数量，毛利也不在系统中计算，而是由自身的财务人员计算。

最低折扣，结算是按最低折扣确定结算数量，销售毛利计算从折扣最低的到最高的顺序计算。

先进先出，是按先进先出法则确定结算数量及计算毛利。

（8）批销退货只检查上次发货数量

选中则只检查上一次的发货情况，检索速度很快；不选，则检查发货历史资料，速度会受影响。

（9）ISBN/自编号唯一

如果选中此项，则在图书资料录入时，扫描完条码，如有相同ISBN号的书目时，系统会在窗口下方提示列出相同条码的书目，可参考资料录入的有关章节。

（10）同时检索ISBN和自编号

在做进销退的各类单据时，扫书时是按自编号+ISBN号的方式检索图书资料。建议用户选中此项。

4、打印参数

打印参数中的内容是系统在打印时的一些设置。

打印类型，“标准单”是按A4幅面的纸张尺寸打印单据，格式是固定的，用户无法更改；选择“自定义单”，用户可以自行调整打印内容和打印宽度；“分类打印”与“自定义单”基本相同，仅在打印时按图书的自定义类别分不同的类打印。用户根据需要选择其中一项，然后点“确定”按钮。

选中“零售不打印”项，在保存零售单时，不提示打印否，直接进入下一张新单；选中“零售自动打印”，每保存完一张零售单，系统自动打印零售单而不提示；都不选则会提示打印否。选中“批发自动打印”，每次保存批销单后，就会自动开始打印而不提问。

这四个选项主要与POS（POS也是一套计算机设备，只是配备的外围设备更适用于零售终端）系统有关。“零售直送打印端口”，通常采用的微型打印机有针式（可打两联）和热敏，还有带自动切纸功能的，但它们与计算机的接口一般有两种，即并行口（LPT1）和串口（COM），用户确定采用的是何种接口方式，在此处选择正确的类型；“使用顾客显示屏”，一般它们都是串口与计算机相连；“使用钱箱”，钱箱可以由打印驱动打开，还可以由顾客显示屏驱动打开，通常由与钱箱相连的那根信号线是跟谁连接的来确定；“使用黑白小显示器”被选中，系统会按最佳的方式显示零售界面。这四项按照POS系统的实际配备情况来选择。

“打印单据页尾备注”就是方便你要在打印单结尾添加说明。比如，在批销单栏内添加“如有问题，请在销后 10天内与本店联系。逾期自理！”字样，那么在打印每张批销单时，结尾就会出现此字样。

打印单据页尾签名，可以按用户的情况自行设定要打印哪些签名项，可以用自己的命名，但各项之间要用“：”号隔开，如图示。

所有以上设置都必须按“确定”按钮才会生效。

在后面专设一章，会就自定义打印窗口中的各项详细设置进行阐述。

5、单号设置

用户在做单时，系统会自动为该单生成一个单号。单号是根据日期来设置的，如200110110001，表示2001年10月11日的第0001号单，继续做单，系统会接着生成200110110002、200110110003……这样的单号。

而系统默认的单号设置，是进货单、进货退货单、报订单共用一个流水号。即表示做一张进货单、一张进货退货单、一张报订单，根据做单的顺序，会安排如200110110001（进货单）、200110110002（进货退货单）、200110110003（报订单）这样的单号给它们。每天这三种单的总量可达到9999条。同样，其它共用流水号的单可参考上图。

“全部单号首位”表示全部的单都会有一个共同的首位。如在此处录入字母“A”，并确定。则单的单号形如：A200110110001。

用户可以设置每种单的单号独立使用一个流水号。方法是先去除“默认现有单号设置”选项，在下面的各种单对应栏内输入不同符号（最多两位），则每一个单的流水号前就会增加此符号，与其它的单号区别开来。这样每种单的总量最多为9999条。

以上系统的默认单号都是按天进行，也可以按月或年，如按月的流水号，7月份的单号为200207000001开始。方便用户电话对单时，只需报尾号就可以。

单号的设置最好开始就设定好，不要随意改动，以免引起自己的混乱。 最后有一选项是“使用客户/供应商流水单号”，选中，除了系统有一个总的流水号，针对每个客户（供应商）在每张单中单独再提供一个流水号，这个流水号是编号+流水号。如，某客户，共销给他十张单，这十张单除了自己的流水号，还有一个类似7-1、7-2、7-3……的流水号。

6、系统维护

系统维护此功能是针对一些特殊情况设计（如用户无法拨号上网进行远程维护或数据库简单的升级等），没有本公司的技术人员进行指导，请勿使用。

使用方法简单，只需将技术人员提供的SQL语句在空白处输入，最后再单击“执行”按钮，就完成了系统维护操作。注意输入语句的标点符号，单引号只能在英文状态下录入，每一条语句一行（不能回车），每一行的末尾不要用标点。

7、其他参数

用户在默认输入法中选择常用的汉字输入法；“进销存自动取全部单位记录”，不选时，进销窗口的单位没有列出，以防备无关人员查看，这时选单位可用简拼进行；“图书录入/查询自动取全部出版社记录”，不选时，出版社的下拉框中也没有任何项出现;“图书资料录入窗口ISBN位置在前”，可以对调图书资料录入窗口中ISBN与自编码的位置；“操作员工号分组权限”，这一条与人员权限有密切关系，详细参考人员权限。

8、折扣管理

（1）批销使用图书折扣

在图书资料输入窗口中，有进货折扣和销售折扣两项，这两项要在进销过程发生实际的作用，就需要选中这时的“批销使用图书折扣”项。当选中此项，则在做进货单时自动出现图书资料中的进货折扣，做批销单时，折扣栏中自动出现图书资料中的销售折扣。

（2）使用图书进货折扣计算库存实洋

此处的图书折扣是指在图书资料录入时的进货折扣。库存的实洋计算，就根据这里给出的折扣来计算，如果折扣全部为1，则库存码洋与实洋相同。

（3）零售默认折扣

在此框中输入折扣数，所有的零售图书就都采用此折扣售出，当然，如果有修改折扣的权限，零售时也可以修改折扣。

（4）零售使用图书折扣

与批销使用图书折扣中的折扣相同。此项与下一项最多只可选一个。

与零售折扣有关项，还有下面的“零售使用自定类别折扣”（将在下面叙述）。它们有个优选顺序，“零售使用自定类别折扣”为第一级，设为1时，则只按自定类别中的折扣；当“零售使用自定类别折扣”为0，而“零售使用图书折扣”选中时，则按图书资料中的批销折扣给出；最后当前两项都不选时，“零售默认折扣”中的折扣数才会起作用。

（5）零售找赊负值自动存为其它费用

选中此项，在零售窗口现金栏如果输入的金额少于应收金额，则少收的部分会自动转入到其它费用项内。如应收77.35，在现金栏输入77，回车保存后，-0.35会计入本单的其它费用。输入超过77.35，就需手动在其它费用栏内录入。

（6）进货/批销取上一次进/销折扣

选中此项，在做进货或批销单时，该品种上一次对应该供应商/客户的折扣会自动出现。

（7）价格折扣管理

窗口下半部分中列表，是价格折扣管理的重点。右侧表是左侧表相关项的明细，下面逐条讲解：

零售使用自定类别折扣，按图书的自定类别给出折扣。设置此项有效，是在其左侧的“是否使用”栏中，将0改为1，再在右侧列表中将对应的类别输入不同的折扣。再单击“保存”按钮。零售时就会按图书的不同类别给出相应的折扣。

零售会员额度折扣，指采用零售会员制的书店，根据消费额度不同，给的折扣也有区别。同样，设置此项有效，先将是否使用栏设为1，再在右侧列表输入额度和相应的折扣。增加项时的步骤，输入额度，按回车，按一下向右的箭头键，输入折扣，然后再按向下的箭头箭，输入下一个额度及折扣，最后单击“保存”按钮。按“删除”按钮时，高亮显示的那一条将被删除。

音像自定类别使用上次批发价，是针对经营音像产品而设定的，需要在“系统参数”的“营业类别”项选择“音像”，再将此处设为“1”，做批发单时，可以自动出现该品种该客户上次的批发价。

自定类别修改单价，对于一些经营品种包括特价书、音像、文具、体育用品等等的用户，其采用的不是折扣管理，而是实洋管理，因此许多时候需要直接修改单价，就要在这里设置。建议用户将需要修改单价的品种独立出来形成系列类别，便于按类修改。除了这些，用户必须为操作者设定人员权限中的条件，才能最终可以修改单价。

如现金处理的方式，在做进销单据时，有“支付方式”项，其中又有多种可选项，有些项用户需要将其做为现金处理，就在这里处理。处理的结果，该单会做为已结的单，并且在结算中出现这一项的统计。

零售使用额度折扣，与零售会员额度折扣操作相似，但作用不同。当零售客户一次性消费达到某一金额时，可以给定一个折扣，当达到另一种更高的额度时，可以给一个更优惠的价格。

零售额度折扣相关自定类别，与上面的零售使用额度折扣有关。如客户消费1000元，某一类的品种不是打折的（象文具类、体育用品等）有800元，而打折的是图书类别为200元，则200元按上面的零售额度折扣计算。这里所说的打折与不打折的类别就是在这设置，打折类别的汇总数就根据上面的零售使用额度折扣计算。


为用户提供数据备份和恢复

为用户提供数据备份和恢复，以防数据的破坏及丢失，并能及时修复。用户在使用系统时，要有备份的思想，可以安排每天或每周做一次备份。可恢复的数据是最后一次备份时间前的数据。所以请注意，恢复操作一定要慎重。系统提供的备份/恢复功能比较灵活，支持单机和网络。

1、备份数据

备份时，首先点中要备份的项目；然后在“备份库文件”栏中确认data\stlib000（或者是其它的路径及文件）；单击“连接”按钮，显示已连接到后台服务器；最后，就可以单击“备份数据”按钮，开始备份。数据较多时，备份时间会较长。

网络备份时，还需要输入服务器的IP地址（或计算机名）。

2、恢复数据

同样在恢复数据时，先选择要恢复的项目，再单击“连接”按钮。然后要注意“恢复时，删除现有记录”这一选项的作用。

1) 选中。即用鼠标在框中点击，如选中，可以看到框中有个钩。在恢复时，将在现有数据库中删除所选项目的所有记录，并将备份库的数据恢复到现有库中。这种方法的特点是速度快，但备份之前的相关数据将不再存在。

2) 不选中，则只恢复备份前的数据，而备份后输入的数据保持不变。

系统恢复数据时默认的备份库是stlib000，否则请输入正确的路径及文件名，网络恢复还要输入服务器的IP地址（或计算机名）。


书目库与应用库

书目库与应用库（所有的进销存都在此库，即所说的数据库）是两个独立的库，系统只在此处与提供的可选书目有联系。其它有关书目的操作，如进销存操作中所选书，都是应用库中的。“导入书目”的作用就是将书目库的书转入应用库，减少手工录入的工作。

在书目库中有十万条记录，根据自己的主要经营品种，导入相关内容，避免不必要的多余书目。有些书目不在库中的，就只有手工录入。

操作方法：

用户给出条件，如ISBN分类中的一种（可以多种条件一起），再点击“查询”按钮，在明细表中出现书目后，只要单击“导入书目”按钮，就开始导入工作。

同样，用以上方法可以多次导入不同的分类书目。为了防止重复书目，可以选择“检测已有书目”。

如果提供的书目中，用户可使用的少，而导入太多的无用书目又占用系统资源，可以采用以下办法，只是有些麻烦：

将货架上的书一本一本的导入。即在查询条件的ISBN号处，用扫描器扫入一本书的ISBN号，单击“查询”按钮，找到，就按“导入书目”按钮，这样的操作可以省略录入书名的工作。否则就在“资料录入”的“图书”中一步步输入。

然后再扫下一本，继续上面的操作。


1

人员权限的功能，包括增加新的使用人员，分配其工号、密码以及名称、部门等。并能根据各人的工作岗位分配不同的使用权限，使其各司其职，避免系统数据被任意删改，造成系统数据与实际统计不符的结果。

1、增加新的操作人员

例如图：新增加一个用户02时，先点击“增加”按钮，输入用户帐号（两位数），名称、用户类型、所在部门和密码等，回车之后光标自动停在“保存”上，再回车，你就可以在下方的栏目中看到你增加的用户“02”，如没有则说明你可能操作有误并没有增加到用户，请参照上述重做。

用户为新操作人员设置的密码为初始密码，他可以修改自身的密码。当他忘记自己的密码时，用户可以进入此窗口，单击“修改”按钮，重新为其设置初始密码。

这里需要注意，01用户是系统的超级用户，不可删除，建议用户正式使用时，将01的通用密码更改。

2、设置权限

增加的每一个新人，其权限是所有权限都有，就此要尽快授予有限的权限。用鼠标在操作人员明细表中选中需要设置权限的人员，再点击“设置权限”按钮，就会弹出“权限设置”窗口。

在权限设置窗口中，你就可以根据自己的需要分配权限。如你想给用户02进货录入和报订录入的权限：，你只需在该复选框点击一下（出现一个勾），表示有此权限，否则无此权限。授予完权限之后，要按“设置确认”按钮，并确认保存，退出。

做完上述步骤后，你就可以用02这个帐号登陆了，如你没有给这个操作员相应的权限，而该操作员想进行此项操作时，系统会提示“对不起，你没有这个权限！”。

“修改权限”包括了修改和删除两项功能。

“仅限零售”是为 POS机设置，界面是最简单的零售界面。“制单单价修改”权限，允许操作员在进销过程中可以直接修改单价。“零售折扣修改”确定操作人员是否有修改折扣的权限。所辖仓库可以指定该操作员只能对某个仓进行操作，或者全部仓。在进销过程中，仓号只会显示授权的那个仓。

对于01用户而言，其权限中的“人员权限”设置对其是无效的，即使用户不允许此权限，但用01登录时，仍可以进入“人员权限”窗口。

3、人员权限分组管理

通过工号分组，可以将操作人员分在不同的组，同一组不能修改另一组的单据（进销收报订退单），修改只能由拥有更高一级工号的人才能操作。以下将详细讲述个体用法。

工号最多支持8位，包括字母、数字及其它符号。采用工号分组方式时，工号设置是有要求的，图示为例。

工号为四位的，按前两位区分组；六位，按前四位区分；八位按前六位区分。工号呈金字塔式进行管理。采用其它符号或字体时，也请两两分组，如AA、AAAA之类。所以支持的人员管理最多分为四级。

例如，某书店，分两组人员倒班，一组4人，设一组长。01为系统管理员，0101为一组长，0102为另一组长，010101、010102、010103为0101组成员，010201、010202、010203为0102组成员。每组成员在人员权限中设置有修改单据的权限，但这时每个组成员只能改自己的单，而改不了其它成员的单，更改不了其它组的单。每个组长也只能改自己组内所做的单，改不了其它组所做的单据。

这样做的好处是可以做到职责分明，不会误改单。特别是大的书城，做分级管理就非常必要。

以上分组生效，必须在“系统维护”—>“系统设置”—>“其它参数”中选中“操作员工号分组权限”。否则操作员不会有以上的限制，只要有修改权限就可以改所有操作员相关的单。

采用此法的书店多为较大型的书店，如果操作员仅由一两个人就可以完成所有的工作，则可不用这种设置。


这个功能是可以不退出系统

这个功能是可以不退出系统，而用另外一个用户名和密码重新进入系统。与开始的登录窗口是一样的。


每个操作人员都可以在此处修改自已的密码

每个操作人员都可以在此处修改自已的密码。当操作人员忘记自己的密码时，请询问01用户（系统管理员）解决，当01用户忘记密码时，请咨询我公司技术部。


可以记录一些重要的日程安排

可以记录一些重要的日程安排，注意的是如果在这里输入没标题的记录时，则不能进行正确的删除。如图：

具体操作：要输入一条记录时，先按“增加”，光标就停在标题一栏中，根据各项标题输入你的内容，完毕之后按保存就可以在下面的明细中可以看你的记录。如要对记录进行修改则先在明细栏中选中要改的记录，再按修改，改完之后请记得保存。


提供直接调用Windows记事本的功能

提供直接调用Windows记事本的功能，因为在系统中支持一些文本文件的处理，如由打印生成的文件、扫描枪形成的文件、系统自动生成的文件等等。此功能是为了方便用户操作而设。


标准单的格式是固定的

标准单的格式是固定的。打印内容包括序号、ISBN编号、名称、出版社、定价、册数、折扣、实洋和仓号。

标题头则是出版社或书店名称，在销售单中的“P”表示批发，“L”表示零售。标题下一行是地址和电话。然后下面的栏中是关于本单的信息，如单号、单位、总册数、总码洋、总实洋等内容。

通常标准单适用于A4大小的纸张，并且用户不用修改打印项目的情况下（宽行连续纸也适用标准单）。

选择标准单后，所有的“进销存”中的单据将全部采用标准单打印，并且可以预览。

修改打印属性，如打印某一页，可选择打印窗口中的“设置”；将打印内容保存为文本格式的文件，选择“保存”；“合适”、“100%”和“等宽”都是预览时用到的各种显示方式。


自定义单则非常灵活

自定义单则非常灵活，用户可以根据实际需要调整打印的项目和顺序，以及字体、页长、页宽等内容。这也是“打印设置”中的重点讲解内容。

在“系统设置”窗口中选择了自定义单打印后，打印所有“进销存”中各种业务单据及书目、库存等内容时，都将会弹出一个打印设置窗口，这其中有多种设置内容。
1、打印“序号”、“栏目”和“宽度”的设置

在打印设置窗口的右半边，就是序号、栏目和宽度的设置内容。

设置“序号”，可以使打印栏目即打印的项目顺序发生变化，用户可以根据自己的需要自行输入相应数字，并选择“样式保存”，按“返回”后再进入打印窗口，就会看到栏目的顺序已经可以按数字大小重新排列好了。

设置“栏目”内容，建议不要修改此项内容，如果一定修改，只需在相关栏中输入文字即可。

设置打印“宽度”，直接在相关栏内输入数字，要记住一个汉字需要占2个单位的位置，一位数字（如序号）只占1个单位的位置，一般打印宽度需要调整几次后，打出来的格式才会比较美观。

2、打印字体的设置

这里的打印字体包括“题头字体”和“打印字体”。系统缺省的题头字体是二号，打印字体是小四。

在“选择字体”按钮右边的下拉框中选择要设置的字体，然后单击“选择字体”，在“字体”窗口中选择自己需要的各种字体、样式、大小、效果和颜色等等。

3、自定义打印样式

用户有时需要打印多种格式的单据，每次都重新设置显得很麻烦，系统允许用户设置自定义的打印样式并保存。

操作步骤：

l 在“标准样式”栏内输入新的格式名称，如“样式一”；

l 修改序号、栏目和宽度；

l 单击“样式保存”按钮。

这样会在样式栏中出现“样式一”的打印样式，删除它只需单击“样式删除”按钮。

4、其它设置

“页长”和“页宽”，一般的A4纸的页长为2104，页宽可适当放大，只要在右边的栏目宽度设置合适就可以。打印的是否是“连续纸”，在其前的复选框中确定。请注意设置完成后，一定要选择“设为默认”。

“类型”中有标准单和详细单，其区别是在打印的标题内容不同，详细单中的标题内容更加全，主要是本单位信息，如税号、开户行、帐号等。

“打印机原值”是系统默认的“页长”和“页宽”。A4为2104*1440，如要打印小单，即为A4纸的一半，则在此设置为1052*720即可。打印机原值是跟打印机的属性有关的，打印机属性中的纸张类型不同，则打印机原值也不同。如果可选纸张类型中没有用户所用的纸张，则可以考虑使用自定义纸张，尺寸量准确。用户使用连续纸时，如果走纸太长，可以将此处的页长适当减少，如页长改为1900。

“打印题头”不选，打印时，本单位的信息不打印出来。

“单头分两列”，可以将单头一部分内容打在单头右侧，不至于单头显得太长。而且置于右侧的位置可以通过“第二列起始位置”调整。

5、零售小票

在许多书店的零售中，需要打印零售小票，这时在打印窗体中，要将“零售小票”项选中，并单击“设为默认”按钮。设置好后，以后打印的零售单均是以小票的形式出现。

6、打印内容保存为其它文件

所有可以打印的内容，都可以保存为文本文件和制表文件（Excel文档）。这项功能相当有用，如用户可以将查询的书目信息制作成征订单，或是以E-mail形式发送给客户；或是直接打印出来，形成征订目录。

先选择要保存的文件类型（文本文件、制表文件）；

再确定保存的路径及文件名，一般系统会自动给出默认值，用户可更改；或者也可以点击“选择文件”按钮，找到要保存的文件。

确定是否“追加”。选中则将新的内容追加到已有的文件未尾，否则执行替换操作。

最后单击“存为文件”按钮，保存成功。

系统有几种特殊样式，不同地方在于打印头显示的内容不一样。标准的内容为：

销售单号: 销售日期: 打印日期:

单位名称:

支付方式: 发货方式: 本单备注:

品种数: 总册数:

总码洋: 总实洋:

实洋合计:壹佰肆拾玖元捌角零分

简易样式1： 单位名称:

单号:

不打实洋 1： 销售单号: 销售日期: 打印日期:

单位名称:

支付方式: 发货方式: 本单备注:

品种数: 总册数:

总码洋:

如何加入这些打印样式？在标准样式的下拉框中，输入“简易样式1”或“不打实洋1”，然后再单击“样式保存”按钮。


设置的第一个步骤就是要设定IP地址

在实图书业管理系统中，需要经过一定的设置过程，才能通过“网络数据交换”使数据上传、下载。要求计算机已经联网，能够互相访问。

设置的第一个步骤就是要设定IP地址，包括服务器和工作站。已经联网的计算机局域网中的任何一台配置较好的电脑都可以作为服务器，操作系统可以是以下面各点中的任何一种（Linux作为服务器的情况不在此处列出）。用户根据自己所安装的操作系统类型查看下面内容。

1、Windows95/98/Me的IP地址设置

在“网上邻居”点鼠标右键，选“属性”，在“配置”栏中的“已经安装了下列网络组件”中有无“TCP/IP”的字样，如有则不用添加TCP/IP 协议。如果没有，则按下列步聚进行：

①在“网络”窗口的“配置”栏里单击“添加” → 在“请选择网络组件类型”窗口的“请选择要安装的网络组件”里面的“协议”后按“添加”，出现“选择网络协议”窗口，在“厂商”栏里选择“Microsoft”，在“网络协议”栏里选择“TCP/IP” → 单击"确定"按钮开始安装。会要求插入相应光盘，或自动找到相应的Windwos系统的安装路径。

②TCP／IP协议安装完成以后，便开始设置。单击“TCP/IP”（选择后面带网卡名称的），单击“属性”，再单击“IP地址”项，选择“指定IP地址”，在IP地址填入有关数字，所有的IP地址前三项必须相同，第四项为0至255的数，自行安排。比如：设定服务器的IP为192.168.0.1（为了以后方便管理，最后的1-9可为服务器保留范围，其他工作站最好安排从10至255的数。）应该特别注意不要使网络中的IP地址发生冲突，即每台机器的IP在网络中应是唯一的，尤其是要区别于主服务器。

填入子网掩码。比如：填入255.255.255.0 （各机器的子网掩码必须统一，这里就都填入"255.255.255.0 "这组数）。

③最后按“确定”按钮，计算机会提示重新启动，重启设定即完成。

查看两台电脑是否连通，可以使用PING命令。在MS-DOS方式下，IP为192.168.0.2的机器，检测是否可以连接IP为192.168.0.1的电脑，可以用PING 192.168.0.1命令。一般情况下，如果提示信息中有:

Replay from 192.168.0.1;bytes=32 time<10ms TTL=128

则表示两台电脑可以通信。

2、Windows NT 4.0 Server的IP地址设置

在“网上邻居”点鼠标右键，选“属性”中的“协议”栏，若无“TCP/IP通讯协议”则按“添加”按钮进行添加。其它步骤与上面的第二步相似，可参考安装。

3、Windows 2000的IP地址设置

在“网上邻居”点鼠标右键，选“属性”，出现“网络和拨号连接”窗口，右击“本地连接”，选“属性”，在“此连接使用下列选定的组件”中单击“Internet协议（TCP/IP）”，确保它前面的复选框为选中。单击“属性”，选中“使用下面的IP地址”，输入相应的IP地址和子网掩码”，方法同上。在此窗口还可以选中“选中后在任务栏中显示图标”，这样在任务栏会出现一个小图标，是否与局域网络连通的情况一目了然。


此种情况指在一个局域网中

此种情况指在一个局域网中，只有一台服务器，它是整个系统数据的存放地，其它计算机都是直接存取服务器中数据库的数据。

首先按照上面讲的方法，设置好所有计算机的IP地址并能互相访问到。然后指定一台配置较好的计算机作为服务器，并安装好操作系统（如果安装Linux和大型数据库环境，则需我公司工程师上门安装、调试）和实图书业管理系统。

服务器上的图书管理系统，在运行时，是与本机的数据库相连的，所以无需其他设置，直接使用就行。记住服务器的IP地址（如：192.168.0.1）或是计算机名（如：ST_Server）。

启动工作站上的管理系统，在要求输入工号和密码的登录窗口出现时，选择“网络”按钮。现进行以下设置。

  • 在设置窗口中先选中“网络”。

  • 在“服务器IP”中输入服务器的IP地址（如192.168.0.1或计算机名ST_Server）。

  • 在“数据库类型”中选择Intrbase（系统缺省类型，其他数据库类型另定）

  • 在“安装路径”中输入服务器的数据库路径，系统默认为c:\program files\stbook\data\stlib。

设置好后按“连接”按钮，连接成功系统会提示“已成功连接到后台服务器”。如果连接成功，按“返回”重新回到登录窗口，输入工号和密码就可完成，这时使用的数据库是服务器上的，而非本机。


对于部门的服务器及其它电脑

这种情况一般指在同一个局域网中有两个以上的计算机作为服务器使用。举例，如在一幢大楼内有一局域网，在门市有数台电脑、批发部有数台电脑、仓库有数台电脑，门市的所有数据存储在门市的某一台机子上，而同样的，批发部和仓库都有自己的服务器存放自己部门的数据，这时可指定其中一台或另外单独的计算机作为中心服务器，即所作的设置能使部门服务器上的数据可以传送到这台服务器的数据库中。

对于部门的服务器及其它电脑，设置方法见上。这里主要讲一下部门服务器向中心服务器传送数据的设置。启动要传送数据的部门服务器上的书业管理系统，进入后，选择“其他功能”下的“系统设置”，单击“拨号参数”页，在这里要设置好“服务器IP”、“数据库类型”和“安装路径”，方法同上。

设置好后，单击“确定”按钮，并“退出”。数据传送时，只要选择“在线书店”菜单下的“数据传送”项，再选择要传送的数据，最后单击“传送”，传送开始和结束时，系统均有相关提示。可以单击“未传数据”查看有多少记录未传。

需要注意的是，各部门的服务器要分配好不同的注册编号才可传送，并在中心服务器的“门市/分店管理”中要按前述章节中设好，才能在中心服务器查看、汇总各部门服务器传送上来的数据。

上述方法同样适用于：各台单机工作在本地的数据库，在需要的时候向服务器传送数据，各台单机的设置是与以上的部门服务器设置相同，相当于部门只使用一台电脑（服务器兼工作站）。

在安装Windows95操作系统的工作站中，使用IP地址可能无法访问服务器，工作站也就无法与服务器的数据库相连，这时在设置窗口的“服务器IP”框中就要输入服务器的计算机名，也能正常工作。


在使用

在使用“网络数据交换”的“数据传送”前，要先使用“拨号上网”，比局域网环境多一步操作。作为接受数据的一方，必须能够提供拨入的功能，因此这台电脑要安装Windows 98第二版、Windows ME、Windows NT 4.0 Server和Windows 2000等操作系统中的一种，并且数据库采用的是InterBase。

Linux等其它系统一般由我公司的工程师上门安装。准备好MODEM和相关电话线，并在系统上安装好MODEM驱动程序。(其它如ISDN等也可按后面的步骤)


用户根据接入服务安装的系统参考下面各点

用户根据接入服务安装的系统参考下面各点。需要注意的是，传送端要分配好不同的注册编号才可传送，并在接入端（服务器）的“门市/分店管理”中要按前述章节设好，才能在服务器查看、汇总各部门传送上来的数据。

1、Windows 98/ME

需要安装“拨号网络”和“拨号网络服务器”。打开“控制面板”，运行“添加/删除程序”，选择“Windows安装程序”，单击“通讯”，再点按“详细资料”，在通讯窗口中选择“拨号网络”和“拨号网络服务器”，并确定，再确定。最后Windows系统开始安装，并且可能会提示插入光盘，将Windows盘插入即可。

正确安装后，顺序点击“开始”——“程序”——“附件”——“通讯”——“拨号网络”，在拨号网络窗口中，选择菜单中的“连接”项，将会有“拨号网络服务器”，选择运行，出现拨号服务器窗口，选中“允许拨入”，并且可以在这里设定要拨入端使用的密码。最后选择“确定”，设置完成。

对于Windows 98/ME作为接入端，是不需要用户名的，密码也可不设，但从安全考虑，设密码是有必要的。所以，拨号方在拨号时的用户名可以任意设定，密码则与接入端设的密码相同。如果要查看数据传送的状态，可以打开拨号网络服务器窗口。

（Windows ME中是叫“拨号服务器”而不是“拨号网络服务器”，与98在名称上有点不同。）

2、Windows NT 4.0

首先，打开“控制面板”，找到“网络”项并运行，选择“服务”单，查看是否有“远程拨号服务”，如果没有则需要安装，即选择“添加”按钮，找到并选相应项确定。

然后，选择“远程拨号服务”的“属性”，在属性窗口中选择“网络”，为整个系统并指定静态IP地址范围后，并确定。

再选择“远程拨号服务”的“配置”按钮，选中“拨入和接收”，并“确定”。

最后，在“域用户管理器”中增加域用户，为每个需要远程拨号的用户分别设置用户名与密码；选择“用户”的属性，在属性窗口中，选择“拨入”按钮，在打开的窗口中选中“给予用户拨入的权限”。

整个NT服务器端的设置就完成了。

而拨号方的用户名和密码就按NT给的输入，不能错误，否则无法连接。

3、Windows 2000

顺序打开“开始”——“程序”——“附件”——“通讯”——“网络和拨号连接”，在网络和拨号连接窗口中，双击“新建连接”；在网络连接向导窗口中单击“下一步”；选中“接受传入的连接”，单击“下一步”；选择连接设备（调制解调器），两次“下一步”；选择允许连接的用户（在用户属性中可以设置连接密码），如果没有要连接的用户，可以“添加”相关用户，完成后单击“下一步”；查看网络组件并确定有TCP/IP协议，一般不做改动，可直接单击“下一步”；最后按“完成”即可。

这时在网络和拨号连接窗口中会出现“传入的连接”图标，今后要是增加新用户或者做其它的改动，只需右击它，在“属性”中修改相应内容，如：选中“连接后在任务栏显示图标”项，就可以知道拨入的情况；在“用户”页面中新建新用户；在“网络”页面中的TCP/IP属性中设定传入的IP地址范围，见图。

同样，拨号方的用户名和密码就按Windows 2000给的输入，不能错误，否则无法连接。

以上三种设置最后都需要手动确定TCP/IP协议的一个IP地址，并输入。一般都是在类似“我的连接”属性中设置。（Windows98/ME会自动确认IP地址为192.168.55.1）


首先

首先，传送方的电脑要设置好拨号连接，设置过程与设置上互联网的方法是一样的，只是这时的拨号号码不再是163、95788、165之类的，而是接入端的电话号码。

然后，设置好拨号连接后，进行测试。双击新建好的连接图标（如“我的连接”），出现连接窗口，这时可以输入用户名和密码了。如果接入端的电脑是安装的Windows 98/ME，拨号端的用户名可以自由取，密码则要使用拨入端设置好的允许拨入密码；如果接入端的电脑是安装的Windows NT/2000，则拨号端的用户名和密码都要使用接入端设置的。以上设好后，单击“连接”，如果连接成功会在任务栏中出现连接的小图标标志，否则请检查所有的设置是否正确。测试成功后可断开连接。

最后，设置实图书业管理系统，进行数据传送。进入管理系统，选择菜单中的“系统维护”项，运行“系统设置”，然后系统设置窗口中单击“拨号参数”页，在“服务器IP”中输入服务器计算机名，在“数据库类型”中选择IntrBase，在“安装路径”中输入接入端电脑的数据库路径（缺省值为c:\program files\stbook\data\stlib）。“数据库名称”、“用户名称”和“密码”系统自动给出，无需用户输入。

到此，传送前的设置就全部结束，现在可以进行数据传送了。步骤如下：

² 运行菜单中“在线书店”下的“拨号上网”项，在“连接”中选择设置好的连接，并输入相应的“拨号用户”和“密码”（可选中“保存密码”，下次启动时可免去输入的麻烦）。然后，单击“拨号”按钮，将听到拨号音，并且拨通后有提示“已经连通”，也可以看任务栏是否有连接成功的小图标标志。

² 运行菜单中“在线书店”下的“数据传送”项，有六类数据可供传送，也可选择部分种类的数据进行传送。在传送前，可以单击“未传数据”按钮，查看有多少未传记录。要传送时，只需单击“传送”按钮即可。系统会提示正在传送数据，结束时也会有提示。

² 传送结束后，运行菜单中“在线书店”下的“拨号上网”项，单击“取消”按钮，将与接入端断开连接。整个传送过程结束。


远程拨号除了可以进行数据传送外

远程拨号除了可以进行数据传送外，还能直接通过拨号登录到远程计算机的数据库（我公司的远程维护也是这个原理）。其操作原理基本上与单一服务器局域网环境相同，只是连接的是电话线而不是网线。有关的拨号设置与以上是相同的，其操作步骤如下：

² 启动实图书业管理系统，在登录窗口中，选择“网络”按钮，出现设置窗口。

² 在设置窗口中，单击“拨号”按钮，出现拨号窗口，按前述所讲拨号。拨通到远程计算机，最小化或关闭拨号窗口。

² 然后到设置窗口，在“服务器IP”中输入远程计算机名或IP地址（远程计算机如果是Windows98/Me，自动分配的IP地址为192.168.55.1），“数据库类型”及“安装路径”也与前面所述相同。单击“连接”按钮，连接成功后，再单击“返回”按钮，返回到登录窗口。

² 在登录窗口，输入相应“工号”及“密码”，并确定。

现在，在实图书业管理系统中查询及做单的操作就是远程计算机中的数据。不过，大多数用户如果采用此方法连网的成本太高，一般都是查询一下远程库（其他分店）中的库存情况，是否还有自己需要的图书，以便调拔或转仓。然后，重新登录到本地。


本篇所述内容是网络版与单机版差异的地方

主要内容：网络操作使用，主要是门市/分店和网络数据交换的使用；局域网的配置；远程拨号网络的配置。但不同用户因业务流程不同，所以其数据传送、下载的方式也不尽相同，有些相对简单，有些则相对复杂。一般在购买本系统之前，已经根据用户的业务流程确定传送、下载的的方式，并由我公司技术人员负责本软件的一些配置。

在菜单中有个特殊项——网络数据交换，它是指书店的连网与数据传送功能，它可以实现以下两个目标：

  • 解决异处、异地的多家连锁店之间数据传送问题，可实时拨号传送、为方便工作可设置定时，自动拨号传送，为节省话费可在数据传送完毕后自动挂断，使用的线路可为普通电话线、ISDN、ADSL等。这样前台连锁店、后台进货及决策部门均可及时掌握整体的销售和库存情况，根据市场需要及时做出相应调整。

  • 利用互联网技术及现有网站平台，可与出版社、供应商、客户之间方便的进行数据交互，信息共享，加速整个销售环节的运转效率。如，可与客户的网站实行书目数据上传、下载。


对于大型的用户

对于大型的用户，一般都要配备专用服务器。特别是大型连锁店及书城，其服务器的操作系统（Linux）和数据库（大型）是由我公司的工程师安装调试。中小型用户的服务器可以兼做工作站，中心数据库采用本软件的默认数据库——InterBase，其安装方法参照本手册，服务器的操作系统则由用户自行安装（建议采用安装较方便和比较稳定的Windows NT/2000）。本章就是关于后者的使用介绍，也可以供大型用户参考。

中心平台服务器是整个系统的核心，因为所有的数据交流最后都是以这台机器作为中心，并且最终的数据也是存储在这台机器上。因此，服务器的安全性、稳定性、可扩充性、可升级性以及售后服务都是很重要的，并且最好能采用双硬盘进行数据备份。

对于大中型书店或出版社，我们推荐使用国际著名的品牌服务器（如IBM、COMPAQ、HP等），其次是国产著名服务器（如浪潮、联想、方正、同创等）。小型系统从经济角度出发，可考虑使用稳定性好的普通PC机做服务器。

根据目前的硬件市场情况，兼容PC服务器一般配置要求CPU为P4-1.6G以上，内存256M以上，硬盘20G以上两块；品牌服务器的CPU主频比较低但其结构是针对服务设计的，特别是Xeon系列可带高达2MCache，内存采用带ECC的256M，硬盘采用SCSI的20G两块。具体配置可灵活，先考虑稳定性，再看运行速度和价格。

服务器可安装的操作系统包括：WINDOWS 9x/NT3.51/4.0/2000Server，Linux。

服务器的数据库可采用：Sybase，MS SQL Server，Oracle，Informix，MySQL，Interbase(系统默认)等等。


除了与单机版相同的准备工作外

除了与单机版相同的准备工作外，还有几项是网络版特有的。（先决条件是网络要连通）

一、门市/分店管理

在“资料录入”菜单下有一项是“门市/分店管理”，是对有多个门市或分店的情况而设立。在系统正式使用时，要做的一个重要工作是在各门市/分店注册，注册时的“系统编号”要事先做好分配。

举例：假设有三家门市，服务器在本店，本店是使用服务器上的数据库数据。分别在各门市注册，本店注册的“系统编号”为90001，北京路分店的为90002，南京路分店的为90003。然后在本店（即服务器端）的“门市/分店管理”中增加分店信息，输入“门市/分店名称”与各门市注册时的名称与编号相对应，如图所示。注意“系统编号”不可错误，否则会造成一些数据传送方面的错误。

当以上都设定正确以后，各门市才能正常传送数据至服务器，以及下载相关数据，而且在本店能够掌握所有店的进销存情况，为企业的分析决策提供有效的数据。

与单机版不同的是，当设置了门市/分店后，在所有的查询窗口中，都会增加了“门市/分店”的选择条件。这些查询窗口包括：图书查询、客户/供应商查询、单据查询、盘盈亏历史查询、库存查询。如图所示，是客户/供应商查询中相比单机版增加的一个条件。

二、系统设置

“系统设置”中的“拨号参数”，它是正确进行数据传送时必须设置的。有关此处的设置参数，说明书中将其单列一章，详细论述，分为局域网和远程拨号，见附录二、三。

“系统参数”中还有一项“是否中心”，指本机是不是作为中心服务器使用。


一

一、数据传送

数据传输的物理环境可以是局域网，也可以是远程拨号网络的，之前要在“系统设置”中进行相关设置。要进行远程数据传送，还必须先执行本菜单项中的“拨号上网”才可以上传和下载数据,局域网则不用这一步。

上传数据包括书目数据、进货/报订数据、库存数据、销售/收订数据、客户/供应商数据、收付款数据；而下取数据有书目数据，还可以下载其它单据，但下载内容还是需我公司技术人员根据业务流程预先设置好，才能下载需要的数据。在传送数据前，可以查看未传送的数据有多少条，只要点按”未传数据”按钮，就会显示出来。

二、网上定单管理/网上书目管理

可实行网上书店的订单/书目管理功能。根据现有库存对收订单进行自动处理，可自动生成批销单，此功能尤其适合处理于有较多的杂志订阅客户的分发工作，可大大减少工作量。但必须有相关网站才。

三、网上浏览

系统将IE内嵌于本系统中，用户可以使用熟悉的浏览工具，而无需重新学习。

四、拨号上网

进行远程数据传送或对网站上数据操作时，需先拨号。拨号之前需在操作系统中先建立好”我的连接”之类的拨号连接，进入这里后，选择相应的“连接”、“拨号用户”和“密码”，并单击“拨号”按钮开始拨号上网，拨号成功后，就可以进行网上或远程数据传送的操作。经常需要传送数据的用户，还可以选中“保存密码”，今后拨号时，就无需再输入用户名和密码了。

传送结束后，再次选择菜单中的“拨号上网”，单击“挂断”按钮，将电话信号中断。

检测IP在此处的作用是，检测本机上网后的IP地址，一般此IP地址是动态分配的，每次拨号上网的IP地址都可能不相同，做远程维护时，技术人员经常会要求知道这个值。如，单击“检测IP”按钮后，会显示类似“IP=192.168.0.108”这样的内容。更为详细的相关设置可以参见远程拨号设置。


升级包括两部分

升级包括两部分，即：应用程序升级和数据库升级。应用程序升级一般会增加新的功能并修正有缺陷的地方。而数据库升级包括使用数据库版本的升级和结构变化的升级。

1、应用程序升级

系统在缺省安装时，会在目录c:\program files\stbook下有一个st2001.exe文件，这就是主程序。只要将新的此文件复制并覆盖c:\program files\stbook下的st2001.exe就完成升级工作。

这样的升级不会对数据库产生影响。用户可以通过我们的网站www.stbook..com.cn下载最新的程序及相关补丁程序。在网站上的升级程序是用压缩软件压缩成为可自动解压的程序。其用法简单，下载后，只要在该压缩文件双击，再按提示解压，完成后生成st2001.exe文件。

2、数据库升级

系统的数据库文件存放于（缺省）c:\program files\stbook\data下，文件名为stlib。所以升级主程序时不会影响此数据库。在一般情况下数据库升级的情况较少出现。

数据库升级主要是需要用户执行一些语句，这些语句或从我公司网上下载，或是通过E-mail、传真发送。用户在下载或收到这样的语句后，打开系统的“系统维护”项的“系统设置”中“系统维护”页面，将升级语句复制粘贴到空白窗口，或是录入（注意正确性），最后单击“执行”按钮，就完成了数据库升级工作。


我公司开发的系统可以通过远程拨号或Internet进行远程维护

我公司开发的系统可以通过远程拨号或Internet进行远程维护，对于通过局域网上网的用户，目前暂时只维护担任中心服务器中的数据。

1、远程拨号维护

用户的电脑要求可以上网，并且已经设置好相关的设备。在进行拨号连接时，将我公司告之的密码和电话填入，再选择“连接”，连接正常会关闭连接窗口，并在任务栏中出现已连通的图标。

然后，我公司技术人员会进行远程数据库的维护，结束时由我方断开连接，用户端的连接也会自动中断，维护过程结束。维护之前用户需要将数据库的存放位置通知我方。

2、Internet远程维护

用户通过拨号上网进行远程维护可节省长途话费，一般情况下，都是采用这种方法。对于用此种方法无法连接的用户就只能采用上一种方法了。

使用这种方法需要我公司的软件支持，其步骤如下：

首先，进入“网络数据交换”项下的“拨号上网”；

然后，在“拨号上网”窗口中，选择“连接”栏的下拉框，选择拨号连接（如：我的连接）；

再输入“拨号用户”和“密码”（如163用户，则输入相应的用户名及密码）；

最后，单击“拨号”按钮，系统开始拨号，并显示是否连通（也可观看任务栏有没有连通的图标）。

连通成功后，请单击“检测IP”，将窗口中出现的一组数字（xxx.xxx.xxx.xxx）记下，用另一部电话告诉我公司技术人员，我们将通过这一组数字地址（IP）进行远程维护。一般此IP地址是动态分配的，所以每次拨号上网后的IP都不一样，需要按“检测IP”按钮才能确定。宽带网用户可在MS-DOS方式下运行IPCONFIG命令检测IP Address。


一

一、价格折扣管理

在《实图书业管理系统》中，有许多地方用到折扣，为了避免用户使用上的混乱，现就这些折扣的用法及注意点着重阐述。

设置各种各样的折扣，目的是为了能在进销退时，出现的折扣为预先设置好的，减轻用户的查询及人为干预，增加使用速度和准确性。

设置价格折扣的地方有“图书资料”、进货管理中的几种单据、出货管理中的几种单据、在“系统设置”的“价格折扣”页面，另外，在“盘点”窗口中也可以修改单价。我们将会分别讲述折扣与价格，讲述折扣时按单讲解，因为所有设置最后都是反映到单据上。

1、折扣

（1）进货单

影响进货单的折扣与这几项有关：进货单中的“统一折扣”；“价格折扣”页中的“批销使用图书折扣”和“进货/批销使用上一次进/销折扣”。

它们全部选中后的优先级别是：“进货/批销使用上一次进/销折扣”、“批销使用图书折扣”、“统一折扣”。表一可以说明它们之间的关系：

表一：进货单某书折扣情况

进货/批销使用上一次进/销折扣 | 上次进货折扣0.5 | √ | × | × | ×
批销使用图书折扣 | 图书资料的进货折扣0.52 | √ | √ | × | ×
统一折扣 | 进货单上的统一折扣0.55 | √ | √ | √ | ×
选择此书将会出现的的折扣数 |  | 0.5 | 0.52 | 0.52 | 0.52

注：√表示选中或有内容，×表示未选中或没有内容。

说明：表一所示是有进货记录的书，没有进货记录的则按其它两项出现相关折扣；如果在录入图书资料时没有录入进货折扣（默认为1），则相对于统一折扣，情况又有些不同，见表二：

表二：图书资料中进货折扣为1的折扣情况

进货/批销使用上一次进/销折扣 | 上次进货折扣0.5 | √ | × | × | ×
批销使用图书折扣 | 图书资料的进货折扣为1 | √ | √ | × | ×
统一折扣 | 进货单上的统一折扣0.55 | √ | √ | √ | ×
选择此书将会出现的的折扣数 |  | 0.5 | 1 | 0.55 | 1

（2）进货退货单和批销退货单

一般进货退货单和批销退货单的折扣是自动按最近一次该供应商/客户的进货/销售给出的。如果没有进货或销售也需要做退货处理，常见的操作就是手动录入折扣，“批销使用图书折扣”选中也会出现图书资料的进货折扣。

（3）批销单

批销单的情况与进货单相似，不同点是一个用的是进货折扣，一个用的是销售折扣，其它情况相同。

（4）零售

零售涉及到的折扣内容较多，只要分清优先级，就不难理解和掌握。

零售单的折扣可由以下各种折扣设置产生：统一折扣（零售单上）、零售使用图书折扣、零售默认折扣、零售使用自定类别折扣、零售会员额度折扣和会员折扣。后几种在“价格折扣”页面上可以看到。

在实际应用当中，通常不会用到以上所有的折扣设置。零售会员额度折扣和会员折扣仅与会员零售有关，对其他零售客户没有影响。零售使用图书折扣指图书资料中的销售折扣，它与零售默认折扣、零售使用自定类别折扣都是在“价格折扣“页面中设置。它们的折扣关系见表三：

表三：零售折扣设置在零售单上的结果

零售使用图书折扣 | 0.85 | √ | × | × | × | ×
统一折扣（零售单上） | 0.9 | √ | √ | ×(0.95) | × (1) | × (1)
零售默认折扣 | 0.95 | √ | √ | √ | ×(1) | ×(1)
零售使用自定类别折扣 | 0.88 | √ | √ | √ | √ | ×
结果 |  | 0.85 | 0.9 | 0.95 | 0.88 | 1

注：“统一折扣”与“零售默认折扣”有着密切的联系，上表中的“统一折扣”，是在打开零售窗口后录入的，如果不录入，它出现的是“零售默认折扣”中的折扣。所以上表“统一折扣”行中括号里出现的折扣就是“零售默认折扣”中的值。注意设置好折扣（除统一折扣）后，最好关闭零售窗口再重新打开一个零售窗口。

“价格折扣”页面中的“零售使用额度折扣”和“零售额度折扣相关自定类别”两项是相关联的，当使用“零售使用额度折扣”时，“零售额度折扣相关自定类别”才会起作用。

“零售使用额度折扣”指当零售客户这次消费额达到某个数量就给相应的折扣，它的优先级别是最高的，比下面的“会员折扣”、“零售会员额度折扣”都要高。

“零售额度折扣相关自定类别”是指指定某些自定类别参与到“零售使用额度折扣”的使用。比如，“六一”儿童节到了，充许少儿类的书消费额达到一百元可享受8折优惠，就可以在这里设置。设置方法如下：

“零售使用额度折扣”为1，右侧列表录入“额度”100，折扣0.8。再设“零售额度折扣相关自定类别”为1，右侧列表的自定类别为“少儿类”的设为1。最后按“保存”，再按“确定”按钮，就完成了。

“零售会员额度折扣”和“会员折扣”，“零售会员额度折扣”指会员消费到某额度时给相应的折扣，优先级比“会员折扣”高，即两者都有折扣，且满足额度要求，则给出“零售会员额度折扣”中的折扣。

2、价格

修改价格的主要目的是给经营特价书、音像、文具及其它商品使用的，《实图书业管理系统》是综合性的管理软件，所以就有这些内容，不使用的可不用理会这部分内容。

“价格折扣”页面中只有“音像自定类别使用上次批发价”、“营业类别音像取资料音像进货价”这两项用到，也容易理解，不再多述。“自定类别修改单价”是指按自定义类别确定在进销退单中能否修改单价。

当市场变化，需要调整产品价格时，除了在资料里修改，还可以在“盘点”窗口中统一修改多种产品的价格。


主营教材教辅与其它经营产品相比

主营教材教辅与其它经营产品相比，有很强的季节性，即主要在春秋两季非常繁忙，如何充分运用《实图书业管理系统》，减轻工作量，提高工作效率就显得很重要。

收报订工作是业务中的重要过程。收订单记录的是客户各种书的订数，报订单记录的是向供应商报上的品种及订数，这两都之间需要通过“转单处理”来处理。这里主要讲过程，而不讲具体的操作步骤，相关的详细操作细节可以参考说明书或帮助中的内容。

首先，客户根据用户提供的订单填写订数，每个客户生成一张或数张收订单；

其次，在“转单处理”中，将收订单汇总（一般可按出版社检索）， 分一次或多次转为不同供货商的报订单；

然后，实际到货时，录入进货单或由报订单转成进货单；

最后，再将进货单按收记录分发，生成批销单或分发单。

通常情况下，客户有增订或补订，这时也是做收订单，如果原收订单还未曾转报订单，也可以在原收订单上修改数量。进货品种少时由报订单转比较方便，如果品种多，还是手工做进货单比较准确。在进货单中用进货分发功能时，注意最后生成的是分发单还是批销单。

如果立即发货，则生成批销单较好，如果需要货备齐后再发货，可生成分发单，因为数张分发单在“转单处理”中可以合并成一张批销。


POS是电子收款机系统

POS是电子收款机系统。PC组成的POS系统和专业厂家专门制作的POS系统相比，后者不仅价格贵，而且配置低，不灵活更换配件，特别是那些原装机的专用性就更不用说了，除了自己配备的软件，对其它软件经常不兼容，因为它们使用的指令集经常是独有的，硬件发生故障，也难在市场上找到兼容的配件，只能送回原厂家维修。现在许多专业POS机也开始做得开放起来，这样就与PC更难于有原则的区分了。

因此，本着经济实用的原则，我们在这里向客户介绍如何建立自己的PC-POS。

POS 的基本组成：主机、钱箱、小票打印机、顾客显示屏、可编程键盘（普通键盘）、条码打印仪、单色小显示器。

主机就是电脑主机，采用小机箱，主板采用集成显卡、网卡的小板，支持CPU能达到奔腾200Mhz以上，内存64M以上，硬盘3G以上。主板最好还有一个以上的扩展槽。

钱箱的打开与小票打印机或顾客显示屏有关，一般在钱箱上有一接口，可以与小票打印机上的接口用线连接（或与顾客显示屏连接），购买时要注意这一点。这样，当打印机一开始打印，钱箱就可打开收钱及找零。钱箱分进口与国产，还分大小，价格在数百元不等。

小票打印机，有针式和热敏的两种。针式可以打两联，一联给客户，一联留底，成本比热敏高一些，而且本身价格也高；热敏机用热敏纸打印，只能打一张，价格比针式机便宜。一般这些打印机除了与主机有连接线外，还应有另一个接口可与钱箱连接。另外，还有一点要留意，小票打印机与主机的接口可以用串口和并口两种，串口可以实现扫描一行打印一行，并口则是一次打完一张单，并口的这种作用在某些情况下非常有用，比如，当正在做一个顾客的单时，因其它原因需要暂停此单，而做下一个顾客的单并打印，当接着做那个暂停顾客的单时并不影响打印。但串口就不行，它是每扫描一本书时，就开始打印上一本的内容，如果暂停此顾客的单并做其他顾客的单，那只能作废此单。

顾客显示屏则直接与主机连接。它也可以驱动钱箱，购买时注意是否有接口，问清楚再买。如果打印机与钱箱连，则顾显是否有接口就不重要了。

可编程键盘可以将零售中使用到的那些键定位在键盘上，无关的键不再出现，这种键盘价格上比普通的电脑键盘要高。当然，普通的电脑键盘也可以直接使用。

条码扫描仪，常见的有激光和红外线，激光距离远、精度高、识别速度快，当然价格也高；红外线没有激光这些条件，但它的价格比激光便宜和很多，一般三百到五百的都有。

单色小显示器一般都用9寸的。或者任何其它的各类彩显都可以使用。


这里所讨论的内容

这里所讨论的内容，适合以零售为主的书店，对以批发业务为主的用户也有参考价值。针对零售的特点，我们给出下面的指南供用户使用时参考。

1、人员管理

（1）工号的管理

工作人员各司其职，每个操作人员分配一个工号，自己掌握密码。使用系统时必须用自己的工号进入。

a、增加新的工号

步骤：打开“系统维护”菜单下的“人员权限”；在打开的窗口中单击“增加”按钮；输入“用户帐号”（最多8位）、用户名称（名字）、用户类型、所在部门、密码、密码确认（与前面的密码相同）；单击“保存”按钮，退出。

b、修改密码

每个第一次进入系统的工号，首先要修改自己的密码。步骤：用自己的工号进入系统；打开“系统维护”菜单下的“修改密码”；输入原密码、新密码；单击“确定”，返回。

c、工号分组

较大的书店，一般都是分组轮班，大的书城还会按分层、分类、分货架等分组，所以原则上一组所做单据，另一组无权修改，只有更高级别的工号才可能修改，这时使用用人员分组管理就非常有效。详细的分组内容可以参考说明书或软件帮助系统有关内容。

（2）人员权限的管理

步骤：用01工号进入系统；打开“系统维护”菜单下的“人员权限”；单击要分配权限的工号；再单击“设置权限”按钮；选择要分配的各权限；最后再单击“设置确认”，退出。

该工号再次进入系统时，权限已经生效。零售人员的权限最少应包括“零售录入”和“类别结算”，其它就按管理的需要分配。

负责仓库进货的人员，应有书目录入、进货录入、书目资料修改等相关权限。以此类推，每个人按自已的责任分配权限。

注意：01用户是系统的超级用户，是软件管理者常用的，不要分配给其他人员使用。当需要时，可以分配给其他有关工号更多的权限，代理01行使权限。

2、折扣管理

折扣管理有几种情况可供选择，用户按照自身情况确定其中一种。将折扣管理正规化，减少随意性，是对书店科学管理的重要环节。更加详细的折扣管理可以参考说明书或帮助系统的有关章节。如果有采用会员制，可以了解会员资料录入中的折扣和零售会员额度折扣。

（1）零售使用图书折扣

如果在录入图书资料时就能确定销售折扣，请在“销售折扣”项中输入。这时需要选中“系统维护”菜单下的“系统设置”，再单击“价格折扣”页面，选中“零售使用图书折扣”项。这样在零售时出现的折扣就是图书资料中的“销售折扣”。

（2）零售使用自定类别折扣

如果在录入图书资料时选择了“自定类别”。那么我们就可以按类别打折。进入“系统维护”菜单下的“系统设置”窗口，再单击“价格折扣”页面，参考下图设置：

再单击“保存”按钮，并“确定”。“1”是使用，“0”是不使用。

“自定类别”中的各项可以在“资料录入”菜单“图书分类”的“自定类别”窗口中增加、删除、修改。

（3）零售使用默认折扣

为所有的零售设置统一的折扣。进入“系统维护”菜单下的“系统设置”窗口，再单击“价格折扣”页面，在“零售默认折扣”栏中输入折扣（比如0.8，表示8折），最后单击“确定”按钮。

（4）手动修改折扣

可以允许零售人员直接修改零售单中的折扣。这时要在人员权限设置中赋予“零售折扣修改”的权限。

以上四种方法各有特点，第一种的折扣划分最细致，可以具体到每一种书，但要求录入资料时就能确定销售折扣；第二种则扩大到类别，可以根据不同情况打折，比如“六一”到了，少儿类的书折扣可以调低，“六一”结束再恢复，灵活性高；第三种最便于管理，因为折扣最简单；第四种是最灵活的，但安全性不高，因为零售人员要知道每种书能打多少折扣。

另外还有一种常用的折扣方式是“零售使用额度折扣”，即当客户本次消费额达到某一数量时，给出相关折扣。并且它的优先级别要高过上面的折扣设置。如下图示。有时还经常结合“零售额度折扣相关自定类别”来设置折扣。

3、操作流程

假设用户初次使用本系统，可以按下面的流程开始使用软件。

（1）01工号进入系统

01 进入后，为各操作人员分配工号。以后每个操作人员必须用自己的工号，便于管理人员，按工号查询销售、结算等其它操作内容，做到责任到人。

（2）基本资料录入

基本资料在开始使用系统的进销功能前应能完成大部分输入。避免销售时再录入，影响销售速度。

这些资料包括图书、供应商、客户（指批发客户，没有批发客户可不录入）、会员（如果有会员就录入此项）。

建议图书资料中正确使用“自定类别”，这会为以后的统计分析盘点等工作带来许多方便，“自定类别”的增加、删除和修改是在“资料录入”菜单下，“图书分类”的“自定类别”窗口中。

在录入图书资料时，其中有一项是“期初库存”，清楚它的用法很重要，以免带来麻烦。“期初库存”这一栏只认第一次录入时的数，并且这时的库存数也变为第一次录入的数，类似于盘点的作用，但又有区别，因为以后再修改“期初库存”都不会有效，不会影响库存数。所以要使用这一项，你只有必须做到每种书的期初库存一次到位。但这常常不太现实，建议用户使用时，不录入“期初库存”，而在“盘点”中完成，可以边盘点边录入图书资料。

（3）系统设置

正式使用进销功能前，有一些设置可以考虑是否需要预先设好，因为这些设置会直接影响单据的某些内容，这些内容是不可更改的，即使下次修改了设置，也不会影响以前所做单据。而有些设置可以在任何时候修改。下面主要讲哪些设置会对单据有不可更改的影响。打开“系统维护”菜单中的“系统设置”窗口。

a、系统参数

“货源结算和毛利计算方式”建议客户选中“先进先出”或“最低折扣”，因为系统要计算毛利，是按进货单的折扣计算，如果不选，则以前的单就不能计算毛利，并且以后的单中，从选中的日期开始，只有有进货的品种才会计算毛利。所以建议开始使用软件时，选中后两种中的一种，不要选“手工计算”。

b、单号设置

l 每种单可以有一个独立的流水号，这就要设置各种单的首位，首位最多两个符号，这时就不要选“默认现有单号设置”；

l 单号流水选择，按天、月、年种；

l 使用客户/供应商流水单号，针对每个客户的销售单、销售退货单生成一个独立的流水号，对每个供应商的进货单、进货退货单生成一个独立的流水号。通常选中这一项主要是为了与客户对帐方便，可以按顺序1、2、3……对下去。

（4）盘点

基本资料录入完成后，建议做一次全面的盘点，确定正确的库存数。有不少用户是在盘点的同时录入资料。详细的盘点过程参考说明书或帮助系统。在盘点窗口中扫描书号，如果已录入，直接输入盘点数；如果没有资料，系统会提示，回车确定，进入资料录入窗口，录入完成“保存”，退出，回到盘点窗口，回车，就出现刚录入的资料，输入盘点数。（详细盘点过程参考说明书或帮助文件的有关内容）

在盘点窗口中同一种书可以出现多次，最后“结束盘点”时，系统会汇总盘点记录，并写入库存。

如果是新开张的店，可以直接使用“进货”，而不用盘点，因为进货的数量是自动加到库存数上的。

另外，系统也支持不做盘点就开始销售，只是这时的库存数是不准确的，用户还是要找个合适的时间做一次盘点。

（5）开始使用系统的进销退等功能开展业务

零售为主的书店，主要用到的功能就是进货、零售、退货、结算、库存查询和一些统计分析。折扣按上面所述先设置好；如果有小票打印机，在零售单打印窗口中要选中“零售小票”；如果每次都打印小票，进入“系统维护”菜单下的“系统设置”窗口，再单击“打印参数”页面，选中“零售自动打印”，并“确定”

4、零售过程

零售过程会出现许多不同情况，学会在系统如何处理，避免销售中不知所措，影响销售。

（1）销售去零头的两种用法

a、其他费用去零

在其他费用一栏输入负的零头数，如应收18.88元，在其他费用一栏输入-0.08，如收20元，则找零1.2元。

b、自动去零

进入“系统维护”菜单下的“系统设置”窗口，打开“折扣管理”页面，选中“零售找赊负值自动存为其他费用”，并“确定”。

销售自动去零举例，如应收18.88元，在现金栏中输入18.8元，则-0.08就自动存到其他费用。这种方法，不论客户给多少现金，都需要输入18.8，而不能输20、50或100这样的数。因为系统计算发现是负值时，才会存为其他费用。

（2）零售打折

如果零售时，没有打折权限，但某些特殊的客户需要更好的折扣，这时可以由有打折权限的人员输入折扣数。方法：单击零售单窗口中的“折扣权限检验”，输入工号和密码，再在零售单中输入折扣，结束后再单击“取消折扣权限”按钮。恢复到初始的零售状态。

其他的打折情况按“折扣管理”中的设定自动执行。要是经常需要手动修改折扣，建议选中“跳转模式”。

（3）做零售单中的问题处理

下面是零售过程中经常碰到的一些情况：

l 客户不要单中的某种书。单击此书，再单击“删除”按钮。（这种情况不适用于采用串口的小票打印机，因为它是每扫一种书就打印上一行，这时应重扫此书，并在数量栏输入相应的负数）

l 某个客户因某个原因暂停做单，但又要给下一个客户做单，重新打开一个零售窗口就可以。（采用串口的小票打印机不能这样做，只能作废此单）

l 退货。由有退货权限的人员处理，打开“出货管理”菜单下的“销售退货”窗口，选择零售客户，再扫此书，输入数量、折扣，最后“保存”。通常退货要凭小票，没有小票的只按书店规定的折扣退。

l 此书资料库没有。这种情况比较特殊，一般都是新书入库时漏录、录错等造成，这时由有权限的人员重新录入此资料，并检查校正进货记录。

（4）结算

“结算”在“帐务管理”菜单下。交接班时营业人员结算，可打印结算单，结算结果应该是备用金加上销售收入。

日结算可以统计当天的所有销售。


有不少客户会问到

有不少客户会问到：为什么我的某种书库存不准？

遇到这样的问题时，您可以让按下面的步骤一步步查，通常都能看出问题来：

查的原则就是确定这本书最后一次盘点时，数量是多少？如果录的是新书目，未盘点，则库存是期初值。

然后再检查盘点日期后或新书录入日期后的进、销、退（分发）的数量，最好是在“进销收报订史查询”中进行查找，按ISBN或书名，得出有关数量，正常情况下，进出与盘点或期初的数量会平衡。

下面所存在的情况会影响上面检查的准确性或者直接造成库存不准。

1、删除过最后一次的盘点历史记录

2、修改过期初库存

期初值在第一次保存后就写入库存，再修改是无效的，即如果期初值是0，保存后再调出此书，修改期初值为10，保存。这时的库存是不动的，只要没有做进销退单，它还是第一次的期初值0。所以一旦修改过期初值，这里的检查就没有作用，因为期初不是第一次录入的值。

3、删除书目，又重新录入相同的书

删除某个书目，在相关的单据中此书目并不删除，这时如果又重新录入相同的书，则在“进销收报订史查询”中，按ISBN或书名所查的数量应该会多。这时应查“进销收报订史查询”中明细的书目编号是否相同，通常会发现有“书目编号”为空的明细（表示此书目删过）或不同，这时应剔除这一部分的数量，计算书目编号与“库存查询”中的书目编号相同的书的数量。如果没有其它影响库存不准的条件，这种书的进销退与库存数会平衡。

注意：每一种书的书目编号是唯一的，即使两种书ISBN、书名、定价完全相同，只要都在图书资料中录入，它们就是做为两种书来处理的。如果删除一种书，原来的书目编号就没有了，再重新录入这种书，它的书目编号又是新的编号，所以不能单凭ISBN或书名就确定它们是相同的书。

4、删单不变库存

删除单据时选中了“删单不变库存”选项。正常的删单，系统会恢复明细中在库存中的相关数量，使库存保持准确。

5、边盘点边营业

在盘点时，做了进货单或销售单时，如果处理不好，会对盘点数产生影响，造成库存不准。详细的盘点处理可以参考说明书或帮助。

造成库存不准后，通常的做法就是重盘一下这本书，用“盘点”功能中的“部分盘点 ”来做。另外注意分发单合并为一张批销单的情况。为了使库存尽量准确，应避免或减少以上情况的出现，对进行上面的操作所造成的结果，要有清晰的认识。